# CVE-2020-15703: aptdaemon allows unprivileged users to test for the presence of local files via the transaction Locale property

> Unprivileged users can determine the existence of arbitrary files on the system by exploiting a lack of input validation in aptdaemon's Locale property.

- **Severity:** Medium 4.0 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Oct 2020
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-wpmr-q825-x4c6, PYSEC-2026-783, UBUNTU-CVE-2020-15703, USN-4537-1

## What is CVE-2020-15703?

CVE-2020-15703 is a medium-severity path traversal vulnerability in Canonical aptdaemon, published on 31 Oct 2020. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

There is no input validation on the Locale property in an apt transaction. An unprivileged user can supply a full path to a writable directory, which lets aptd read a file as root. Having a symlink in place results in an error message if the file exists, and no error otherwise. This way an unprivileged user can check for the existence of any files on the system as root.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2020-15703?

3 open source packages ship an affected version, including aptdaemon. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `aptdaemon` | PyPI | All versions | 1.1.1 |
| `aptdaemon` | PyPI | All versions | 1.1.1 |
| `aptdaemon` | PyPI | All versions | 1.1.1 |

Products: Aptdaemon Project Aptdaemon.

## How do I fix CVE-2020-15703?

Upgrade aptdaemon to 1.1.1 or later.

## Is CVE-2020-15703 being exploited?

There is no known exploitation of CVE-2020-15703 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15703 and fix it if it is affected.

What it is: CVE-2020-15703 is a medium-severity path traversal vulnerability in Canonical aptdaemon, published on 31 Oct 2020. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-15703 in the wild and no public exploit code.

Affected packages and fixed versions:
- aptdaemon (PyPI): affected all versions; fixed in 1.1.1
- aptdaemon (PyPI): affected all versions; fixed in 1.1.1
- aptdaemon (PyPI): affected all versions; fixed in 1.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15703/ (Markdown: https://insights.sbomify.com/CVE-2020-15703/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15703
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15703
- OSV: https://osv.dev/vulnerability/CVE-2020-15703

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15703/
Summaries are generated and may contain mistakes; the official description above is the record.
