CVE-2020-15720 Security feature bypass in n/a

Medium 6.8 Published Updated

Dogtag PKI client tools failed to validate SSL certificates, allowing attackers to perform Person-in-the-Middle attacks and intercept sensitive data.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2020-15720?

CVE-2020-15720 is a medium-severity vulnerability in n/a, published on 14 Jul 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

In Dogtag PKI through 10.8.3, the pki.client.PKIConnection class did not enable python-requests certificate validation. Since the verify parameter was hard-coded in all request functions, it was not possible to override the setting. As a result, tools making use of this class, such as the pki-server command, may have been vulnerable to Person-in-the-Middle attacks in certain non-localhost use cases. This is fixed in 10.9.0-b1.

Weakness: CWE-295

Which versions are affected by CVE-2020-15720?

It affects 1 product.

Products include Dogtagpki Dogtagpki.

How do I fix CVE-2020-15720?

Upgrade to a fixed version.

Is CVE-2020-15720 being exploited?

There is no known exploitation of CVE-2020-15720 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2020-15720, GHSA-hpcm-hcj8-c96c, UBUNTU-CVE-2020-15720.

Is CVE-2020-15720 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free