{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-15720 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2020-15720 is a medium-severity vulnerability in n/a, published on 14 Jul 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-15720 and fix it if it is affected.\n\nWhat it is: CVE-2020-15720 is a medium-severity vulnerability in n/a, published on 14 Jul 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-15720 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-15720/ (Markdown: https://insights.sbomify.com/CVE-2020-15720/index.md)","id":"CVE-2020-15720","markdown":"https://insights.sbomify.com/CVE-2020-15720/index.md","name":"CVE-2020-15720","record":{"aliases":["DEBIAN-CVE-2020-15720","GHSA-hpcm-hcj8-c96c","UBUNTU-CVE-2020-15720"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Dogtag PKI client","requires_auth":"none","summary":"Dogtag PKI client tools failed to validate SSL certificates, allowing attackers to perform Person-in-the-Middle attacks and intercept sensitive data.","user_interaction":"required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"dogtagpki","vendor":"dogtagpki"}],"cvss":{"score":6.8,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-295","name":"Improper Certificate Validation"}],"description":"In Dogtag PKI through 10.8.3, the pki.client.PKIConnection class did not enable python-requests certificate validation. Since the verify parameter was hard-coded in all request functions, it was not possible to override the setting. As a result, tools making use of this class, such as the pki-server command, may have been vulnerable to Person-in-the-Middle attacks in certain non-localhost use cases. This is fixed in 10.9.0-b1.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Security feature bypass in n/a","id":"CVE-2020-15720","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"security_feature_bypass","year":"2020"},"n_packages":0,"n_references":3,"next":{"headline":"Cross-site Scripting in RosarioSIS","id":"CVE-2020-15721"},"packages":[],"prev":{"headline":"Security feature bypass in n/a","id":"CVE-2020-15719"},"products":["n/a"],"published":"2020-07-14","related":[{"cvss_score":8.1,"headline":"Business logic in pki-core","id":"CVE-2021-20179","kev_date_added":null,"published":"2021-03-15"},{"cvss_score":7.8,"headline":"Information disclosure in pki-server","id":"CVE-2021-3551","kev_date_added":null,"published":"2022-02-16"},{"cvss_score":7.5,"headline":"XML external entity in Dogtag PKI","id":"CVE-2022-2414","kev_date_added":null,"published":"2022-07-29"},{"cvss_score":7.5,"headline":"Auth bypass in pki-core","id":"CVE-2018-1080","kev_date_added":null,"published":"2018-07-02"},{"cvss_score":6.1,"headline":"Cross-site scripting in pki-core","id":"CVE-2020-25715","kev_date_added":null,"published":"2021-05-28"},{"cvss_score":6.1,"headline":"Cross-site scripting in pki-core","id":"CVE-2020-1721","kev_date_added":null,"published":"2021-04-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Dogtag PKI client tools failed to validate SSL certificates, allowing attackers to perform Person-in-the-Middle attacks and intercept sensitive data.","url":"https://insights.sbomify.com/CVE-2020-15720/"}