# CVE-2020-15720: Security feature bypass in n/a

> Dogtag PKI client tools failed to validate SSL certificates, allowing attackers to perform Person-in-the-Middle attacks and intercept sensitive data.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Jul 2020
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2020-15720, GHSA-hpcm-hcj8-c96c, UBUNTU-CVE-2020-15720

## What is CVE-2020-15720?

CVE-2020-15720 is a medium-severity vulnerability in n/a, published on 14 Jul 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In Dogtag PKI through 10.8.3, the pki.client.PKIConnection class did not enable python-requests certificate validation. Since the verify parameter was hard-coded in all request functions, it was not possible to override the setting. As a result, tools making use of this class, such as the pki-server command, may have been vulnerable to Person-in-the-Middle attacks in certain non-localhost use cases. This is fixed in 10.9.0-b1.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2020-15720?

It affects 1 product.


Products: Dogtagpki Dogtagpki.

## How do I fix CVE-2020-15720?

Upgrade to a fixed version.

## Is CVE-2020-15720 being exploited?

There is no known exploitation of CVE-2020-15720 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-20179](https://insights.sbomify.com/CVE-2021-20179/): Business logic in pki-core (high 8.1)
- [CVE-2021-3551](https://insights.sbomify.com/CVE-2021-3551/): Information disclosure in pki-server (high 7.8)
- [CVE-2022-2414](https://insights.sbomify.com/CVE-2022-2414/): XML external entity in Dogtag PKI (high 7.5)
- [CVE-2018-1080](https://insights.sbomify.com/CVE-2018-1080/): Auth bypass in pki-core (high 7.5)
- [CVE-2020-25715](https://insights.sbomify.com/CVE-2020-25715/): Cross-site scripting in pki-core (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15720 and fix it if it is affected.

What it is: CVE-2020-15720 is a medium-severity vulnerability in n/a, published on 14 Jul 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-15720 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15720/ (Markdown: https://insights.sbomify.com/CVE-2020-15720/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15720
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15720
- OSV: https://osv.dev/vulnerability/CVE-2020-15720

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15720/
Summaries are generated and may contain mistakes; the official description above is the record.
