# CVE-2020-15777: Maven Extension plugin for Gradle Enterprise vulnerable to Deserialization of Untrusted Data

> Attackers can achieve remote code execution and local privilege escalation via unsafe Java deserialization in the Gradle Enterprise Maven Extension plugin.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Aug 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-vp55-fhxx-vcx8

## What is CVE-2020-15777?

CVE-2020-15777 is a high-severity unsafe deserialization vulnerability in n/a, published on 25 Aug 2020. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

An issue was discovered in the Maven Extension plugin before 1.6 for Gradle Enterprise. The extension uses a socket connection to send serialized Java objects. Deserialization is not restricted to an allow-list, thus allowing an attacker to achieve code execution via a malicious deserialization gadget chain. The socket is not bound exclusively to localhost. The port this socket is assigned to is randomly selected and is not intentionally exposed to the public (either by design or documentation). This could potentially be used to achieve remote code execution and local privilege escalation.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2020-15777?

2 open source packages ship an affected version, including com.gradle:gradle-enterprise-maven-extension. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.gradle:gradle-enterprise-maven-extension` | Maven | All versions | 1.6 |
| `com.gradle:gradle-enterprise-maven-extension` | Maven | All versions | 1.6 |

Products: Gradle Maven.

## How do I fix CVE-2020-15777?

Upgrade com.gradle:gradle-enterprise-maven-extension to 1.6 or later.

## Is CVE-2020-15777 being exploited?

There is no known exploitation of CVE-2020-15777 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15777 and fix it if it is affected.

What it is: CVE-2020-15777 is a high-severity unsafe deserialization vulnerability in n/a, published on 25 Aug 2020. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-15777 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.gradle:gradle-enterprise-maven-extension (Maven): affected all versions; fixed in 1.6
- com.gradle:gradle-enterprise-maven-extension (Maven): affected all versions; fixed in 1.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15777/ (Markdown: https://insights.sbomify.com/CVE-2020-15777/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15777
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15777
- OSV: https://osv.dev/vulnerability/CVE-2020-15777

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15777/
Summaries are generated and may contain mistakes; the official description above is the record.
