# CVE-2020-15877: Exposure of Resource to Wrong Sphere in LibreNMS

> Normal users can bypass access controls to perform administrative actions due to incorrect middleware configuration in LibreNMS.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Jul 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-3c33-3465-fhx2

## What is CVE-2020-15877?

CVE-2020-15877 is a high-severity missing authorization vulnerability in Librenms Librenms, published on 21 Jul 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue was discovered in LibreNMS before 1.65.1. It has insufficient access control for normal users because of "'guard' => 'admin'" instead of "'middleware' => ['can:admin']" in routes/web.php.

## Which versions are affected by CVE-2020-15877?

2 open source packages ship an affected version, including librenms/librenms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `librenms/librenms` | Packagist | All versions | 1.65.1 |
| `librenms/librenms` | Packagist | All versions | 1.65.1 |

Products: Librenms Librenms.

## How do I fix CVE-2020-15877?

Upgrade librenms/librenms to 1.65.1 or later.

## Is CVE-2020-15877 being exploited?

There is no known exploitation of CVE-2020-15877 in the wild and no public exploit code.

## Other vulnerabilities in Librenms Librenms

- [CVE-2023-4982](https://insights.sbomify.com/CVE-2023-4982/): Cross-site Scripting (XSS) - Stored in librenms/librenms (critical 9.8)
- [CVE-2022-29712](https://insights.sbomify.com/CVE-2022-29712/): Command injection in librenms (critical 9.8)
- [CVE-2021-44278](https://insights.sbomify.com/CVE-2021-44278/): Path traversal in librenms/librenms (critical 9.8)
- [CVE-2019-10665](https://insights.sbomify.com/CVE-2019-10665/): LibreNMS Information Disclosure (critical 9.8)
- [CVE-2018-20434](https://insights.sbomify.com/CVE-2018-20434/): LibreNMS arbitrary OS commands execution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15877 and fix it if it is affected.

What it is: CVE-2020-15877 is a high-severity missing authorization vulnerability in Librenms Librenms, published on 21 Jul 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-15877 in the wild and no public exploit code.

Affected packages and fixed versions:
- librenms/librenms (Packagist): affected all versions; fixed in 1.65.1
- librenms/librenms (Packagist): affected all versions; fixed in 1.65.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15877/ (Markdown: https://insights.sbomify.com/CVE-2020-15877/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15877
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15877
- OSV: https://osv.dev/vulnerability/CVE-2020-15877

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15877/
Summaries are generated and may contain mistakes; the official description above is the record.
