{"answers":{"affected":"1 open source package ship an affected version, including lua. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-15888 in the wild and no public exploit code.","fix":"Upgrade lua to 5.4.1 or later.","what":"CVE-2020-15888 is a high-severity use after free vulnerability in n/a, published on 21 Jul 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-15888 and fix it if it is affected.\n\nWhat it is: CVE-2020-15888 is a high-severity use after free vulnerability in n/a, published on 21 Jul 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-15888 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- lua (Bitnami): affected from 5.4.0; fixed in 5.4.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-15888/ (Markdown: https://insights.sbomify.com/CVE-2020-15888/index.md)","id":"CVE-2020-15888","markdown":"https://insights.sbomify.com/CVE-2020-15888/index.md","name":"CVE-2020-15888","record":{"aliases":["AZL-6670","BIT-lua-2020-15888","DEBIAN-CVE-2020-15888","GHSA-4f5v-4r5w-g4x3"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Lua scripting library","requires_auth":"none","summary":"Attackers can exploit heap corruption in Lua to execute arbitrary code or cause denial of service via stack resize and garbage collection interactions.","user_interaction":"required","vuln_class":"use_after_free"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"lua","vendor":"lua"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"},{"id":"CWE-416","name":"Use After Free"},{"id":"CWE-125","name":"Out-of-bounds Read"}],"description":"Lua through 5.4.0 mishandles the interaction between stack resizes and garbage collection, leading to a heap-based buffer overflow, heap-based buffer over-read, or use-after-free.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Use after free in n/a","id":"CVE-2020-15888","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"use_after_free","year":"2020"},"n_packages":1,"n_references":6,"next":{"headline":"Memory corruption in n/a","id":"CVE-2020-15889"},"packages":[{"ecosystem":"Bitnami","fixed":["5.4.1"],"introduced":["5.4.0"],"last_affected":[],"package":"lua","purl":"pkg:bitnami/lua","source":"BIT-lua-2020-15888"}],"prev":{"headline":"MunkiReport Software Update module is vulnerable to SQL injection","id":"CVE-2020-15887"},"products":["n/a"],"published":"2020-07-21","related":[{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2020-15889","kev_date_added":null,"published":"2020-07-21"},{"cvss_score":7.5,"headline":"Memory corruption in n/a","id":"CVE-2021-45985","kev_date_added":null,"published":"2023-04-10"},{"cvss_score":7.5,"headline":"Null dereference in n/a","id":"CVE-2020-24369","kev_date_added":null,"published":"2020-08-17"},{"cvss_score":6.3,"headline":"Use after free in n/a","id":"CVE-2021-44964","kev_date_added":null,"published":"2022-03-14"},{"cvss_score":5.5,"headline":"Null dereference in n/a","id":"CVE-2020-15945","kev_date_added":null,"published":"2020-07-24"},{"cvss_score":5.3,"headline":"Memory corruption in n/a","id":"CVE-2020-24371","kev_date_added":null,"published":"2020-08-17"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Attackers can exploit heap corruption in Lua to execute arbitrary code or cause denial of service via stack resize and garbage collection interactions.","url":"https://insights.sbomify.com/CVE-2020-15888/"}