# CVE-2020-15888: Use after free in n/a

> Attackers can exploit heap corruption in Lua to execute arbitrary code or cause denial of service via stack resize and garbage collection interactions.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Jul 2020
- **Updated:** 4 Aug 2024
- **Also known as:** AZL-6670, BIT-lua-2020-15888, DEBIAN-CVE-2020-15888, GHSA-4f5v-4r5w-g4x3

## What is CVE-2020-15888?

CVE-2020-15888 is a high-severity use after free vulnerability in n/a, published on 21 Jul 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Lua through 5.4.0 mishandles the interaction between stack resizes and garbage collection, leading to a heap-based buffer overflow, heap-based buffer over-read, or use-after-free.

Weakness: CWE-787 (Out-of-bounds Write), CWE-416 (Use After Free), CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2020-15888?

1 open source package ship an affected version, including lua. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lua` | Bitnami | From 5.4.0 | 5.4.1 |

Products: Lua Lua.

## How do I fix CVE-2020-15888?

Upgrade lua to 5.4.1 or later.

## Is CVE-2020-15888 being exploited?

There is no known exploitation of CVE-2020-15888 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-15889](https://insights.sbomify.com/CVE-2020-15889/): Memory corruption in n/a (critical 9.8)
- [CVE-2021-45985](https://insights.sbomify.com/CVE-2021-45985/): Memory corruption in n/a (high 7.5)
- [CVE-2020-24369](https://insights.sbomify.com/CVE-2020-24369/): Null dereference in n/a (high 7.5)
- [CVE-2021-44964](https://insights.sbomify.com/CVE-2021-44964/): Use after free in n/a (medium 6.3)
- [CVE-2020-15945](https://insights.sbomify.com/CVE-2020-15945/): Null dereference in n/a (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15888 and fix it if it is affected.

What it is: CVE-2020-15888 is a high-severity use after free vulnerability in n/a, published on 21 Jul 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-15888 in the wild and no public exploit code.

Affected packages and fixed versions:
- lua (Bitnami): affected from 5.4.0; fixed in 5.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15888/ (Markdown: https://insights.sbomify.com/CVE-2020-15888/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15888
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15888
- OSV: https://osv.dev/vulnerability/CVE-2020-15888

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15888/
Summaries are generated and may contain mistakes; the official description above is the record.
