CVE-2020-15899 Grin insufficient data validation
High 7.5
Published
Updated
Check this codebase for CVE-2020-15899 and fix it if it is affected.
What it is: CVE-2020-15899 is a high-severity vulnerability in n/a, published on 28 Jul 2020.
Exploitation: There is no known exploitation of CVE-2020-15899 in the wild and no public exploit code.
Affected packages and fixed versions:
- grin (crates.io): affected from 3.0.0; fixed in 4.0.0
- grin (crates.io): affected from 3.0.0; fixed in 4.0.0
Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.
Reference: https://insights.sbomify.com/CVE-2020-15899/ (Markdown: https://insights.sbomify.com/CVE-2020-15899/index.md)
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2020-15899?
CVE-2020-15899 is a high-severity vulnerability in n/a, published on 28 Jul 2020.
Official description
Grin 3.0.0 before 4.0.0 has insufficient validation of data related to Mimblewimble.
Weakness: CWE-345
Which versions are affected by CVE-2020-15899?
2 open source packages ship an affected version, including grin. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
grin crates.io | From 3.0.0 | 4.0.0 |
grin crates.io | From 3.0.0 | 4.0.0 |
Products include Grin Grin.
How do I fix CVE-2020-15899?
Upgrade grin to 4.0.0 or later.
Is CVE-2020-15899 being exploited?
There is no known exploitation of CVE-2020-15899 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as GHSA-p75g-gcv5-42qg.