# CVE-2020-15904: bsdiff4 out-of-bounds write via patch file

> A buffer overflow in the bsdiff4 library allows attackers to write to heap memory via crafted patch files, potentially leading to code execution.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Jul 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-f8m3-jpxr-hm5x, PYSEC-2020-30

## What is CVE-2020-15904?

CVE-2020-15904 is a high-severity memory corruption vulnerability in n/a, published on 22 Jul 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

A buffer overflow in the patching routine of bsdiff4 before 1.2.0 allows an attacker to write to heap memory (beyond allocated bounds) via a crafted patch file.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2020-15904?

3 open source packages ship an affected version, including bsdiff4. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bsdiff4` | PyPI | All versions | 1.2.0 |
| `bsdiff4` | PyPI | All versions | 1.2.0 |
| `bsdiff4` | PyPI | All versions | 1.2.0 |

Products: Pypi Bsdiff4.

## How do I fix CVE-2020-15904?

Upgrade bsdiff4 to 1.2.0 or later.

## Is CVE-2020-15904 being exploited?

There is no known exploitation of CVE-2020-15904 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15904 and fix it if it is affected.

What it is: CVE-2020-15904 is a high-severity memory corruption vulnerability in n/a, published on 22 Jul 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-15904 in the wild and no public exploit code.

Affected packages and fixed versions:
- bsdiff4 (PyPI): affected all versions; fixed in 1.2.0
- bsdiff4 (PyPI): affected all versions; fixed in 1.2.0
- bsdiff4 (PyPI): affected all versions; fixed in 1.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15904/ (Markdown: https://insights.sbomify.com/CVE-2020-15904/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15904
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15904
- OSV: https://osv.dev/vulnerability/CVE-2020-15904

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15904/
Summaries are generated and may contain mistakes; the official description above is the record.
