# CVE-2020-15945: Null dereference in n/a

> A segmentation fault in Lua's debug module allows attackers to cause a denial of service via crafted scripts.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jul 2020
- **Updated:** 19 Feb 2025
- **Also known as:** AZL-40818, AZL-6671, BIT-lua-2020-15945, DEBIAN-CVE-2020-15945, GHSA-4fp8-99qh-27p3, JLSEC-2026-554, MINI-mrqg-mw4v-pqqc

## What is CVE-2020-15945?

CVE-2020-15945 is a medium-severity vulnerability in n/a, published on 24 Jul 2020. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Lua 5.4.0 (fixed in 5.4.1) has a segmentation fault in changedline in ldebug.c (e.g., when called by luaG_traceexec) because it incorrectly expects that an oldpc value is always updated upon a return of the flow of control to a function.

## Which versions are affected by CVE-2020-15945?

1 open source package ship an affected version, including lua. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lua` | Bitnami | From 5.3.1 | 5.4.0 |

Products: Lua Lua.

## How do I fix CVE-2020-15945?

Upgrade lua to 5.4.0 or later.

## Is CVE-2020-15945 being exploited?

There is no known exploitation of CVE-2020-15945 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-15889](https://insights.sbomify.com/CVE-2020-15889/): Memory corruption in n/a (critical 9.8)
- [CVE-2020-15888](https://insights.sbomify.com/CVE-2020-15888/): Use after free in n/a (high 8.8)
- [CVE-2021-45985](https://insights.sbomify.com/CVE-2021-45985/): Memory corruption in n/a (high 7.5)
- [CVE-2020-24369](https://insights.sbomify.com/CVE-2020-24369/): Null dereference in n/a (high 7.5)
- [CVE-2021-44964](https://insights.sbomify.com/CVE-2021-44964/): Use after free in n/a (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15945 and fix it if it is affected.

What it is: CVE-2020-15945 is a medium-severity vulnerability in n/a, published on 24 Jul 2020. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-15945 in the wild and no public exploit code.

Affected packages and fixed versions:
- lua (Bitnami): affected from 5.3.1; fixed in 5.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15945/ (Markdown: https://insights.sbomify.com/CVE-2020-15945/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15945
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15945
- OSV: https://osv.dev/vulnerability/CVE-2020-15945

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15945/
Summaries are generated and may contain mistakes; the official description above is the record.
