# CVE-2020-16164: Security feature bypass in n/a

> Attackers can bypass RPKI access restrictions or cause denial of service on routing systems by withholding specific validation files.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 30 Jul 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-h28g-f96v-jhrg, GHSA-q76j-58cx-wp5v

## What is CVE-2020-16164?

CVE-2020-16164 is a high-severity vulnerability in n/a, published on 30 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in RIPE NCC RPKI Validator 3.x through 3.1-2020.07.06.14.28. It allows remote attackers to bypass intended access restrictions or to cause a denial of service on dependent routing systems by strategically withholding RPKI Route Origin Authorisation ".roa" files or X509 Certificate Revocation List files from the RPKI relying party's view. NOTE: some third parties may regard this as a preferred behavior, not a vulnerability

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2020-16164?

2 open source packages ship an affected version, including net.ripe.rpki:rpki-validator-3. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `net.ripe.rpki:rpki-validator-3` | Maven | All versions | 3.2-2020.10.28.23.06 |
| `net.ripe.rpki:rpki-validator-3` | Maven | All versions | 3.2-2020.10.28.23.06 |

Products: Ripe Rpki Validator 3.

## How do I fix CVE-2020-16164?

Upgrade net.ripe.rpki:rpki-validator-3 to 3.2-2020.10.28.23.06 or later.

## Is CVE-2020-16164 being exploited?

There is no known exploitation of CVE-2020-16164 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-16163](https://insights.sbomify.com/CVE-2020-16163/): Security feature bypass in n/a (critical 9.1)
- [CVE-2020-16162](https://insights.sbomify.com/CVE-2020-16162/): Security feature bypass in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-16164 and fix it if it is affected.

What it is: CVE-2020-16164 is a high-severity vulnerability in n/a, published on 30 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-16164 in the wild and no public exploit code.

Affected packages and fixed versions:
- net.ripe.rpki:rpki-validator-3 (Maven): affected all versions; fixed in 3.2-2020.10.28.23.06
- net.ripe.rpki:rpki-validator-3 (Maven): affected all versions; fixed in 3.2-2020.10.28.23.06

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-16164/ (Markdown: https://insights.sbomify.com/CVE-2020-16164/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-16164
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-16164
- OSV: https://osv.dev/vulnerability/CVE-2020-16164

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-16164/
Summaries are generated and may contain mistakes; the official description above is the record.
