# CVE-2020-16251: HashiCorp Vault Authentication bypass

> Attackers can bypass authentication in HashiCorp Vault when the GCP GCE auth method is enabled, potentially gaining unauthorized access.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Aug 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-vault-2020-16251, GHSA-4mp7-2m29-gqxf, GO-2024-2488

## What is CVE-2020-16251?

CVE-2020-16251 is a high-severity authentication bypass vulnerability in Hashicorp Vault, published on 26 Aug 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

HashiCorp Vault and Vault Enterprise versions 0.8.3 and newer, when configured with the GCP GCE auth method, may be vulnerable to authentication bypass. Fixed in 1.2.5, 1.3.8, 1.4.4, and 1.5.1.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2020-16251?

10 open source packages ship an affected version, including github.com/hashicorp/vault and vault. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hashicorp/vault` | Go | From 0.8.3 | 1.2.5, 1.3.8, 1.4.4, 1.5.1 |
| `github.com/hashicorp/vault` | Go | From 0.8.3 | 1.2.5 |
| `github.com/hashicorp/vault` | Go | From 0.8.3 | 1.2.5 |
| `github.com/hashicorp/vault` | Go | From 1.3.0 | 1.3.8 |
| `github.com/hashicorp/vault` | Go | From 1.3.0 | 1.3.8 |
| `github.com/hashicorp/vault` | Go | From 1.4.0 | 1.4.4 |
| `github.com/hashicorp/vault` | Go | From 1.4.0 | 1.4.4 |
| `github.com/hashicorp/vault` | Go | From 1.5.0 | 1.5.1 |
| `github.com/hashicorp/vault` | Go | From 1.5.0 | 1.5.1 |
| `vault` | Bitnami | From 0.8.3 | 1.2.5, 1.3.8, 1.4.4, 1.5.1 |

Products: Hashicorp Vault.

## How do I fix CVE-2020-16251?

Upgrade github.com/hashicorp/vault to a fixed version for your release line: 1.2.5, 1.3.8, 1.4.4 or 1.5.1.

## Is CVE-2020-16251 being exploited?

There is no known exploitation of CVE-2020-16251 in the wild and no public exploit code.

## Other vulnerabilities in Hashicorp Vault

- [CVE-2020-35192](https://insights.sbomify.com/CVE-2020-35192/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2020-12757](https://insights.sbomify.com/CVE-2020-12757/): Improper Input Validation in HashiCorp Vault (critical 9.8)
- [CVE-2025-6000](https://insights.sbomify.com/CVE-2025-6000/): Arbitrary Remote Code Execution via Plugin Catalog Abuse (critical 9.1)
- [CVE-2022-40186](https://insights.sbomify.com/CVE-2022-40186/): HashiCorp Vault vulnerable to incorrect metadata access (critical 9.1)
- [CVE-2022-36129](https://insights.sbomify.com/CVE-2022-36129/): Missing authorization in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-16251 and fix it if it is affected.

What it is: CVE-2020-16251 is a high-severity authentication bypass vulnerability in Hashicorp Vault, published on 26 Aug 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-16251 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/hashicorp/vault (Go): affected from 0.8.3; fixed in 1.2.5, 1.3.8, 1.4.4, 1.5.1
- github.com/hashicorp/vault (Go): affected from 0.8.3; fixed in 1.2.5
- github.com/hashicorp/vault (Go): affected from 0.8.3; fixed in 1.2.5
- github.com/hashicorp/vault (Go): affected from 1.3.0; fixed in 1.3.8
- github.com/hashicorp/vault (Go): affected from 1.3.0; fixed in 1.3.8
- github.com/hashicorp/vault (Go): affected from 1.4.0; fixed in 1.4.4
- github.com/hashicorp/vault (Go): affected from 1.4.0; fixed in 1.4.4
- github.com/hashicorp/vault (Go): affected from 1.5.0; fixed in 1.5.1
- github.com/hashicorp/vault (Go): affected from 1.5.0; fixed in 1.5.1
- vault (Bitnami): affected from 0.8.3; fixed in 1.2.5, 1.3.8, 1.4.4, 1.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-16251/ (Markdown: https://insights.sbomify.com/CVE-2020-16251/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-16251
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-16251
- OSV: https://osv.dev/vulnerability/CVE-2020-16251

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-16251/
Summaries are generated and may contain mistakes; the official description above is the record.
