{"answers":{"affected":"2 open source packages ship an affected version, including field_test. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-16252 in the wild and no public exploit code.","fix":"Upgrade field_test to 0.4.0 or later.","what":"CVE-2020-16252 is a medium-severity vulnerability in n/a, published on 5 Aug 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-16252 and fix it if it is affected.\n\nWhat it is: CVE-2020-16252 is a medium-severity vulnerability in n/a, published on 5 Aug 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-16252 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- field_test (RubyGems): affected from 0.2.0; fixed in 0.4.0\n- field_test (RubyGems): affected from 0.2.0; fixed in 0.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-16252/ (Markdown: https://insights.sbomify.com/CVE-2020-16252/index.md)","id":"CVE-2020-16252","markdown":"https://insights.sbomify.com/CVE-2020-16252/index.md","name":"CVE-2020-16252","record":{"aliases":["GHSA-w542-cpp9-r3g7"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby Field Test gem","requires_auth":"none","summary":"The Field Test gem for Ruby is vulnerable to Cross-Site Request Forgery, allowing attackers to perform unauthorized actions on behalf of users.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"field_test","vendor":"field_test_project"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"The Field Test gem 0.2.0 through 0.3.2 for Ruby allows CSRF.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Field Test CSRF vulnerability","id":"CVE-2020-16252","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"csrf","year":"2020"},"n_packages":2,"n_references":2,"next":{"headline":"PgHero gem allows CSRF","id":"CVE-2020-16253"},"packages":[{"ecosystem":"RubyGems","fixed":["0.4.0"],"introduced":["0.2.0"],"last_affected":[],"package":"field_test","purl":null,"source":"GHSA-w542-cpp9-r3g7"},{"ecosystem":"RubyGems","fixed":["0.4.0"],"introduced":["0.2.0"],"last_affected":[],"package":"field_test","purl":"pkg:gem/field_test","source":"GHSA-w542-cpp9-r3g7"}],"prev":{"headline":"HashiCorp Vault Authentication bypass","id":"CVE-2020-16251"},"products":["n/a"],"published":"2020-08-05","related":[{"cvss_score":5.3,"headline":"field_test gem contains injection vulnerability","id":"CVE-2019-13146","kev_date_added":null,"published":"2019-07-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"The Field Test gem for Ruby is vulnerable to Cross-Site Request Forgery, allowing attackers to perform unauthorized actions on behalf of users.","url":"https://insights.sbomify.com/CVE-2020-16252/"}