{"answers":{"affected":"2 open source packages ship an affected version, including pghero. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-16253 in the wild and no public exploit code.","fix":"Upgrade pghero to 2.7.0 or later.","what":"CVE-2020-16253 is a high-severity vulnerability in n/a, published on 5 Aug 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-16253 and fix it if it is affected.\n\nWhat it is: CVE-2020-16253 is a high-severity vulnerability in n/a, published on 5 Aug 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-16253 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pghero (RubyGems): affected all versions; fixed in 2.7.0\n- pghero (RubyGems): affected all versions; fixed in 2.7.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-16253/ (Markdown: https://insights.sbomify.com/CVE-2020-16253/index.md)","id":"CVE-2020-16253","markdown":"https://insights.sbomify.com/CVE-2020-16253/index.md","name":"CVE-2020-16253","record":{"aliases":["GHSA-v6fx-752r-ccp2"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby performance monitoring gem","requires_auth":"none","summary":"The PgHero Ruby gem is vulnerable to Cross-Site Request Forgery, allowing attackers to perform unauthorized actions on behalf of authenticated users.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"pghero","vendor":"pghero_project"}],"cvss":{"score":8.1,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"The PgHero gem through 2.6.0 for Ruby allows CSRF.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PgHero gem allows CSRF","id":"CVE-2020-16253","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"csrf","year":"2020"},"n_packages":2,"n_references":2,"next":{"headline":"CSS Injection in Chartkick gem","id":"CVE-2020-16254"},"packages":[{"ecosystem":"RubyGems","fixed":["2.7.0"],"introduced":["0"],"last_affected":[],"package":"pghero","purl":null,"source":"GHSA-v6fx-752r-ccp2"},{"ecosystem":"RubyGems","fixed":["2.7.0"],"introduced":["0"],"last_affected":[],"package":"pghero","purl":"pkg:gem/pghero","source":"GHSA-v6fx-752r-ccp2"}],"prev":{"headline":"Field Test CSRF vulnerability","id":"CVE-2020-16252"},"products":["n/a"],"published":"2020-08-05","related":[{"cvss_score":7.5,"headline":"PgHero Allows Information Disclosure Through EXPLAIN Feature","id":"CVE-2023-22626","kev_date_added":null,"published":"2023-01-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"The PgHero Ruby gem is vulnerable to Cross-Site Request Forgery, allowing attackers to perform unauthorized actions on behalf of authenticated users.","url":"https://insights.sbomify.com/CVE-2020-16253/"}