# CVE-2020-1699: Path traversal in ceph

> An unauthenticated attacker can exploit a path traversal flaw in the Ceph dashboard to disclose sensitive information from the host machine.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Apr 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-ceph-2020-1699, DEBIAN-CVE-2020-1699, GHSA-c7h3-g28j-x6jq

## What is CVE-2020-1699?

CVE-2020-1699 is a high-severity path traversal vulnerability in The Ceph Project ceph, published on 21 Apr 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A path traversal flaw was found in the Ceph dashboard implemented in upstream versions v14.2.5, v14.2.6, v15.0.0 of Ceph storage and has been fixed in versions 14.2.7 and 15.1.0. An unauthenticated attacker could use this flaw to cause information disclosure on the host machine running the Ceph dashboard.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2020-1699?

1 open source package ship an affected version, including ceph. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ceph` | Bitnami | From 14.2.5 to 14.2.5 | None |

Products: Linuxfoundation Ceph, Redhat Ceph Storage.

## How do I fix CVE-2020-1699?

Upgrade to a fixed version.

## Is CVE-2020-1699 being exploited?

There is no known exploitation of CVE-2020-1699 in the wild and no public exploit code.

## Other vulnerabilities in The Ceph Project ceph

- [CVE-2020-10736](https://insights.sbomify.com/CVE-2020-10736/): Missing authorization in ceph (high 8.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-1699 and fix it if it is affected.

What it is: CVE-2020-1699 is a high-severity path traversal vulnerability in The Ceph Project ceph, published on 21 Apr 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-1699 in the wild and no public exploit code.

Affected packages and fixed versions:
- ceph (Bitnami): affected from 14.2.5 up to 14.2.5; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-1699/ (Markdown: https://insights.sbomify.com/CVE-2020-1699/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-1699
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-1699
- OSV: https://osv.dev/vulnerability/CVE-2020-1699

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-1699/
Summaries are generated and may contain mistakes; the official description above is the record.
