# CVE-2020-1714: Improper Input Validation in Keycloak

> Attackers can achieve remote code execution in Keycloak by injecting malicious serialized Java objects due to unsafe deserialization practices.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 May 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-m6mm-q862-j366, RHSA-2020:2814, RHSA-2020:2816

## What is CVE-2020-1714?

CVE-2020-1714 is a high-severity unsafe deserialization vulnerability in Redhat Keycloak, published on 13 May 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A flaw was found in Keycloak before version 11.0.0, where the code base contains usages of ObjectInputStream without type checks. This flaw allows an attacker to inject arbitrarily serialized Java Objects, which would then get deserialized in a privileged context and potentially lead to remote code execution.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2020-1714?

4 open source packages ship an affected version, including org.keycloak:keycloak-common and org.keycloak:keycloak-core. It affects 7 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.keycloak:keycloak-common` | Maven | All versions | 11.0.0 |
| `org.keycloak:keycloak-common` | Maven | All versions | 11.0.0 |
| `org.keycloak:keycloak-core` | Maven | All versions | 11.0.0 |
| `org.keycloak:keycloak-core` | Maven | All versions | 11.0.0 |
| `keycloak-adapter-sso7_4-eap6` | Red Hat:jboss_enterprise_application_platform:6::el6 | All versions | 0:9.0.4-1.redhat_00001.1.ep6.el6 |
| `keycloak-saml-adapter-sso7_4-eap6` | Red Hat:jboss_enterprise_application_platform:6::el6 | All versions | 0:9.0.4-1.redhat_00001.1.ep6.el6 |
| `keycloak-adapter-sso7_4-eap6` | Red Hat:jboss_enterprise_application_platform:6::el7 | All versions | 0:9.0.4-1.redhat_00001.1.ep6.el7 |
| `keycloak-saml-adapter-sso7_4-eap6` | Red Hat:jboss_enterprise_application_platform:6::el7 | All versions | 0:9.0.4-1.redhat_00001.1.ep6.el7 |
| `eap7-keycloak-adapter-sso7_4` | Red Hat:jboss_enterprise_application_platform:7.3::el6 | All versions | 0:9.0.4-1.redhat_00001.1.el6eap |
| `eap7-keycloak-saml-adapter-sso7_4` | Red Hat:jboss_enterprise_application_platform:7.3::el6 | All versions | 0:9.0.4-1.redhat_00001.1.el6eap |
| `eap7-keycloak-adapter-sso7_4` | Red Hat:jboss_enterprise_application_platform:7.3::el7 | All versions | 0:9.0.4-1.redhat_00001.1.el7eap |
| `eap7-keycloak-saml-adapter-sso7_4` | Red Hat:jboss_enterprise_application_platform:7.3::el7 | All versions | 0:9.0.4-1.redhat_00001.1.el7eap |
| `eap7-keycloak-adapter-sso7_4` | Red Hat:jboss_enterprise_application_platform:7.3::el8 | All versions | 0:9.0.4-1.redhat_00001.1.el8eap |
| `eap7-keycloak-saml-adapter-sso7_4` | Red Hat:jboss_enterprise_application_platform:7.3::el8 | All versions | 0:9.0.4-1.redhat_00001.1.el8eap |

Products: Quarkus Quarkus, Redhat Decision Manager, Redhat Jboss Fuse, Redhat Keycloak, Redhat Openshift Application Runtimes, Redhat Process Automation, Redhat Single Sign-On.

## How do I fix CVE-2020-1714?

Upgrade org.keycloak:keycloak-common to 11.0.0 or later.

## Is CVE-2020-1714 being exploited?

There is no known exploitation of CVE-2020-1714 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Keycloak

- [CVE-2022-4116](https://insights.sbomify.com/CVE-2022-4116/): Code injection in quarkus dev ui config editor (critical 9.8)
- [CVE-2022-2466](https://insights.sbomify.com/CVE-2022-2466/): Quarkus does not terminate HTTP requests header context (critical 9.8)
- [CVE-2024-12225](https://insights.sbomify.com/CVE-2024-12225/): Io.quarkus:quarkus-security-webauthn: quarkus webauthn unexpected authentication bypass (critical 9.1)
- [CVE-2026-39852](https://insights.sbomify.com/CVE-2026-39852/): Quarkus authorization bypass via semicolon path normalization inconsistency (high 8.8)
- [CVE-2022-0981](https://insights.sbomify.com/CVE-2022-0981/): Privilege escalation in quarkus (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-1714 and fix it if it is affected.

What it is: CVE-2020-1714 is a high-severity unsafe deserialization vulnerability in Redhat Keycloak, published on 13 May 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-1714 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.keycloak:keycloak-common (Maven): affected all versions; fixed in 11.0.0
- org.keycloak:keycloak-common (Maven): affected all versions; fixed in 11.0.0
- org.keycloak:keycloak-core (Maven): affected all versions; fixed in 11.0.0
- org.keycloak:keycloak-core (Maven): affected all versions; fixed in 11.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-1714/ (Markdown: https://insights.sbomify.com/CVE-2020-1714/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-1714
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-1714
- OSV: https://osv.dev/vulnerability/CVE-2020-1714

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-1714/
Summaries are generated and may contain mistakes; the official description above is the record.
