{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-1716 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2020-1716 is a high-severity vulnerability in ceph-ansible, published on 28 May 2021. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-1716 and fix it if it is affected.\n\nWhat it is: CVE-2020-1716 is a high-severity vulnerability in ceph-ansible, published on 28 May 2021. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-1716 in the wild and no public exploit code.\n\nAffected product: ceph-ansible. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-1716/ (Markdown: https://insights.sbomify.com/CVE-2020-1716/index.md)","id":"CVE-2020-1716","markdown":"https://insights.sbomify.com/CVE-2020-1716/index.md","name":"CVE-2020-1716","record":{"aliases":["GHSA-v27v-7hmw-76p2","RHSA-2020:2231","RLSA-2020:2231"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["privilege_escalation","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Ceph deployment tool","requires_auth":"low_privilege","summary":"Hardcoded default passwords in ceph-ansible allow authenticated attackers to gain administrator access and modify Ceph cluster configurations.","user_interaction":"not_required","vuln_class":"hardcoded_credentials"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"ceph-ansible","vendor":"ceph"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-798","name":"Use of Hard-coded Credentials"}],"description":"A flaw was found in the ceph-ansible playbook where it contained hardcoded passwords that were being used as default passwords while deploying Ceph services. Any authenticated attacker can abuse this flaw to brute-force Ceph deployments, and gain administrator access to Ceph clusters via the Ceph dashboard to initiate read, write, and delete Ceph clusters and also modify Ceph cluster configurations. Versions before ceph-ansible 6.0.0alpha1 are affected.","ecosystems":["Red Hat:ceph_storage:4::el7","Red Hat:ceph_storage:4::el8","Rocky Linux:8"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Hardcoded credentials in ceph-ansible","id":"CVE-2020-1716","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"hardcoded_credentials","year":"2020"},"n_packages":3,"n_references":1,"next":{"headline":"Generation of Error Message Containing Sensitive Information in Keycloak","id":"CVE-2020-1717"},"packages":[{"ecosystem":"Red Hat:ceph_storage:4::el7","fixed":["0:4.0.23-1.el7cp"],"introduced":["0"],"last_affected":[],"package":"ceph-ansible","purl":"pkg:rpm/redhat/ceph-ansible","source":"RHSA-2020:2231"},{"ecosystem":"Red Hat:ceph_storage:4::el8","fixed":["0:4.0.23-1.el8cp"],"introduced":["0"],"last_affected":[],"package":"ceph-ansible","purl":"pkg:rpm/redhat/ceph-ansible","source":"RHSA-2020:2231"},{"ecosystem":"Rocky Linux:8","fixed":["1:7.1-1.el8"],"introduced":["0"],"last_affected":[],"package":"smartmontools","purl":"pkg:rpm/rocky-linux/smartmontools?distro=rocky-linux-8\u0026epoch=1","source":"RLSA-2020:2231"}],"prev":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2020-1715"},"products":["ceph-ansible"],"published":"2021-05-28","related":[{"cvss_score":5.5,"headline":"Information disclosure in ceph-ansible","id":"CVE-2020-25677","kev_date_added":null,"published":"2020-12-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"BSD","name":"Rocky Linux","prefix":"RLSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Hardcoded default passwords in ceph-ansible allow authenticated attackers to gain administrator access and modify Ceph cluster configurations.","url":"https://insights.sbomify.com/CVE-2020-1716/"}