{"answers":{"affected":"2 open source packages ship an affected version, including io.smallrye.config:smallrye-config. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-1729 in the wild and no public exploit code.","fix":"Upgrade io.smallrye.config:smallrye-config to 1.6.2 or later.","what":"CVE-2020-1729 is a medium-severity vulnerability in SmallRye, published on 28 May 2021. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-1729 and fix it if it is affected.\n\nWhat it is: CVE-2020-1729 is a medium-severity vulnerability in SmallRye, published on 28 May 2021. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-1729 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- io.smallrye.config:smallrye-config (Maven): affected all versions; fixed in 1.6.2\n- io.smallrye.config:smallrye-config (Maven): affected all versions; fixed in 1.6.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-1729/ (Markdown: https://insights.sbomify.com/CVE-2020-1729/index.md)","id":"CVE-2020-1729","markdown":"https://insights.sbomify.com/CVE-2020-1729/index.md","name":"CVE-2020-1729","record":{"aliases":["GHSA-54fx-gm74-q676"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"SmallRye API","requires_auth":"high_privilege","summary":"Attackers can bypass permission checks to access the ClassLoader, potentially compromising data confidentiality in applications using SmallRye.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"smallrye_config","vendor":"redhat"}],"cvss":{"score":4.4,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"A flaw was found in SmallRye's API through version 1.6.1. The API can allow other code running within the application server to potentially obtain the ClassLoader, bypassing any permissions checks that should have been applied. The largest threat from this vulnerability is a threat to data confidentiality. This is fixed in SmallRye 1.6.2","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Permissions bypass in SmallRye","id":"CVE-2020-1729","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"security_feature_bypass","year":"2020"},"n_packages":2,"n_references":1,"next":{"headline":"Null dereference in libssh","id":"CVE-2020-1730"},"packages":[{"ecosystem":"Maven","fixed":["1.6.2"],"introduced":["0"],"last_affected":[],"package":"io.smallrye.config:smallrye-config","purl":null,"source":"GHSA-54fx-gm74-q676"},{"ecosystem":"Maven","fixed":["1.6.2"],"introduced":["0"],"last_affected":[],"package":"io.smallrye.config:smallrye-config","purl":"pkg:maven/io.smallrye.config/smallrye-config","source":"GHSA-54fx-gm74-q676"}],"prev":{"headline":"Improper Restriction of Rendered UI Layers or Frames in Keycloak","id":"CVE-2020-1728"},"products":["SmallRye"],"published":"2021-05-28","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Attackers can bypass permission checks to access the ClassLoader, potentially compromising data confidentiality in applications using SmallRye.","url":"https://insights.sbomify.com/CVE-2020-1729/"}