# CVE-2020-1729: Permissions bypass in SmallRye

> Attackers can bypass permission checks to access the ClassLoader, potentially compromising data confidentiality in applications using SmallRye.

- **Severity:** Medium 4.4 (`CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 May 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-54fx-gm74-q676

## What is CVE-2020-1729?

CVE-2020-1729 is a medium-severity vulnerability in SmallRye, published on 28 May 2021. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A flaw was found in SmallRye's API through version 1.6.1. The API can allow other code running within the application server to potentially obtain the ClassLoader, bypassing any permissions checks that should have been applied. The largest threat from this vulnerability is a threat to data confidentiality. This is fixed in SmallRye 1.6.2

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2020-1729?

2 open source packages ship an affected version, including io.smallrye.config:smallrye-config. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.smallrye.config:smallrye-config` | Maven | All versions | 1.6.2 |
| `io.smallrye.config:smallrye-config` | Maven | All versions | 1.6.2 |

Products: Redhat Smallrye Config.

## How do I fix CVE-2020-1729?

Upgrade io.smallrye.config:smallrye-config to 1.6.2 or later.

## Is CVE-2020-1729 being exploited?

There is no known exploitation of CVE-2020-1729 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-1729 and fix it if it is affected.

What it is: CVE-2020-1729 is a medium-severity vulnerability in SmallRye, published on 28 May 2021. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-1729 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.smallrye.config:smallrye-config (Maven): affected all versions; fixed in 1.6.2
- io.smallrye.config:smallrye-config (Maven): affected all versions; fixed in 1.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-1729/ (Markdown: https://insights.sbomify.com/CVE-2020-1729/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-1729
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-1729
- OSV: https://osv.dev/vulnerability/CVE-2020-1729

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-1729/
Summaries are generated and may contain mistakes; the official description above is the record.
