CVE-2020-1730 Null dereference in libssh
A null pointer dereference in libssh allows remote attackers to cause a denial of service via crafted connection handling.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-1730?
CVE-2020-1730 is a medium-severity vulnerability in Canonical Ubuntu Linux, published on 13 Apr 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A flaw was found in libssh versions before 0.8.9 and before 0.9.4 in the way it handled AES-CTR (or DES ciphers if enabled) ciphers. The server or client could crash when the connection hasn't been fully initialized and the system tries to cleanup the ciphers when closing the connection. The biggest threat from this vulnerability is system availability.
Weakness: CWE-476
Which versions are affected by CVE-2020-1730?
It affects 6 products.
Linux distribution packages (8)
redhat-virtualization-host Red Hat:rhev_hypervisor:4.4::el8 | All versions | 0:4.4.3-20201116.0.el8_3 |
redhat-virtualization-host-image-update Red Hat:rhev_hypervisor:4.4::el8 | All versions | 0:4.4.3-20201116.0.el8_3 |
libssh SUSE:Linux Enterprise Module for Basesystem 15 SP1 | All versions | 0.8.7-10.12.1 |
libssh SUSE:Linux Enterprise Server 12 SP5 | All versions | 0.8.7-3.9.1 |
libssh SUSE:Linux Enterprise Server for SAP Applications 12 SP5 | All versions | 0.8.7-3.9.1 |
libssh SUSE:Linux Enterprise Software Development Kit 12 SP5 | All versions | 0.8.7-3.9.1 |
libssh openSUSE:Leap 15.1 | All versions | 0.8.7-lp151.2.12.1 |
libssh openSUSE:Tumbleweed | All versions | 0.9.6-2.1 |
Products include Canonical Ubuntu Linux, Fedoraproject Fedora, Libssh Libssh, Netapp Cloud Backup, Oracle Mysql Workbench, Redhat Enterprise Linux.
How do I fix CVE-2020-1730?
Upgrade to a fixed version.
Is CVE-2020-1730 being exploited?
There is no known exploitation of CVE-2020-1730 in the wild and no public exploit code.
Other vulnerabilities in Canonical Ubuntu Linux
Sources
Also known as ALPINE-CVE-2020-1730, DEBIAN-CVE-2020-1730, GHSA-6rh3-m266-5m77, MGASA-2020-0171, RHSA-2020:5218, SUSE-SU-2020:0967-1 and 5 more.