CVE-2020-1733 Ansible vulnerable to Exposure of Resource to Wrong Sphere and Insecure Temporary File
An attacker can exploit a race condition in Ansible's temporary directory creation to gain control of the become user, leading to privilege escalation.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2020-1733?
CVE-2020-1733 is a medium-severity vulnerability in Debian Debian Linux, published on 11 Mar 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
A race condition flaw was found in Ansible Engine 2.7.17 and prior, 2.8.9 and prior, 2.9.6 and prior when running a playbook with an unprivileged become user. When Ansible needs to run a module with become user, the temporary directory is created in /var/tmp. This directory is created with "umask 77 && mkdir -p <dir>"; this operation does not fail if the directory already exists and is owned by another user. An attacker could take advantage to gain control of the become user as the target directory can be retrieved by iterating '/proc/<pid>/cmdline'.
Which versions are affected by CVE-2020-1733?
7 open source packages ship an affected version, including ansible. It affects 6 products.
| Package | Affected | Fixed in |
|---|---|---|
ansible PyPI | All versions | 2.7.17, 2.8.8, 2.9.6 |
ansible PyPI | All versions | 2.7.17 |
ansible PyPI | All versions | 2.7.17 |
ansible PyPI | From 2.8.0a1 | 2.8.11 |
ansible PyPI | From 2.8.0a1 | 2.8.11 |
ansible PyPI | From 2.9.0a1 | 2.9.7 |
1 more packages
ansible PyPI | From 2.9.0a1 | 2.9.7 |
Products include Debian Debian Linux, Fedoraproject Fedora, Redhat Ansible, Redhat Ansible Tower, Redhat Cloudforms Management Engine, Redhat Openstack.
How do I fix CVE-2020-1733?
Upgrade ansible to a fixed version for your release line: 2.7.17, 2.8.8, 2.9.6 or 2.8.11.
Is CVE-2020-1733 being exploited?
There is no known exploitation of CVE-2020-1733 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as ALPINE-CVE-2020-1733, DEBIAN-CVE-2020-1733, GHSA-g4mq-6fp5-qwcf, PYSEC-2020-5, UBUNTU-CVE-2020-1733.