# CVE-2020-1733: Ansible vulnerable to Exposure of Resource to Wrong Sphere and Insecure Temporary File

> An attacker can exploit a race condition in Ansible's temporary directory creation to gain control of the become user, leading to privilege escalation.

- **Severity:** Medium 5.0 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 Mar 2020
- **Updated:** 4 Aug 2024
- **Also known as:** ALPINE-CVE-2020-1733, DEBIAN-CVE-2020-1733, GHSA-g4mq-6fp5-qwcf, PYSEC-2020-5, UBUNTU-CVE-2020-1733

## What is CVE-2020-1733?

CVE-2020-1733 is a medium-severity vulnerability in Debian Debian Linux, published on 11 Mar 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

A race condition flaw was found in Ansible Engine 2.7.17 and prior, 2.8.9 and prior, 2.9.6 and prior when running a playbook with an unprivileged become user. When Ansible needs to run a module with become user, the temporary directory is created in /var/tmp. This directory is created with "umask 77 && mkdir -p <dir>"; this operation does not fail if the directory already exists and is owned by another user. An attacker could take advantage to gain control of the become user as the target directory can be retrieved by iterating '/proc/<pid>/cmdline'.

Weakness: CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization), CWE-377 (DEPRECATED: Insecure Temporary File)

## Which versions are affected by CVE-2020-1733?

7 open source packages ship an affected version, including ansible. It affects 6 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ansible` | PyPI | All versions | 2.7.17, 2.8.8, 2.9.6 |
| `ansible` | PyPI | All versions | 2.7.17 |
| `ansible` | PyPI | All versions | 2.7.17 |
| `ansible` | PyPI | From 2.8.0a1 | 2.8.11 |
| `ansible` | PyPI | From 2.8.0a1 | 2.8.11 |
| `ansible` | PyPI | From 2.9.0a1 | 2.9.7 |
| `ansible` | PyPI | From 2.9.0a1 | 2.9.7 |

Products: Debian Debian Linux, Fedoraproject Fedora, Redhat Ansible, Redhat Ansible Tower, Redhat Cloudforms Management Engine, Redhat Openstack.

## How do I fix CVE-2020-1733?

Upgrade ansible to a fixed version for your release line: 2.7.17, 2.8.8, 2.9.6 or 2.8.11.

## Is CVE-2020-1733 being exploited?

There is no known exploitation of CVE-2020-1733 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-1733 and fix it if it is affected.

What it is: CVE-2020-1733 is a medium-severity vulnerability in Debian Debian Linux, published on 11 Mar 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-1733 in the wild and no public exploit code.

Affected packages and fixed versions:
- ansible (PyPI): affected all versions; fixed in 2.7.17, 2.8.8, 2.9.6
- ansible (PyPI): affected all versions; fixed in 2.7.17
- ansible (PyPI): affected all versions; fixed in 2.7.17
- ansible (PyPI): affected from 2.8.0a1; fixed in 2.8.11
- ansible (PyPI): affected from 2.8.0a1; fixed in 2.8.11
- ansible (PyPI): affected from 2.9.0a1; fixed in 2.9.7
- ansible (PyPI): affected from 2.9.0a1; fixed in 2.9.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-1733/ (Markdown: https://insights.sbomify.com/CVE-2020-1733/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-1733
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-1733
- OSV: https://osv.dev/vulnerability/CVE-2020-1733

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-1733/
Summaries are generated and may contain mistakes; the official description above is the record.
