# CVE-2020-1736: Incorrect Permission Assignment for Critical Resource in Ansible

> Ansible Engine fails to restrict file permissions during atomic moves, potentially exposing sensitive data to unauthorized users.

- **Severity:** Low 2.2 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Mar 2020
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2020-1736, GHSA-x7jh-595q-wq82, PYSEC-2020-8, UBUNTU-CVE-2020-1736

## What is CVE-2020-1736?

CVE-2020-1736 is a low-severity vulnerability in Fedoraproject Fedora, published on 16 Mar 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

A flaw was found in Ansible Engine when a file is moved using atomic_move primitive as the file mode cannot be specified. This sets the destination files world-readable if the destination file does not exist and if the file exists, the file could be changed to have less restrictive permissions before the move. This could lead to the disclosure of sensitive data. All versions in 2.7.x, 2.8.x and 2.9.x branches are believed to be vulnerable.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource)

## Which versions are affected by CVE-2020-1736?

3 open source packages ship an affected version, including ansible. It affects 5 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ansible` | PyPI | All versions | 2.7.17, 2.8.9, 2.9.6 |
| `ansible` | PyPI | From 2.7.0 to 2.10.0 | None |
| `ansible` | PyPI | From 2.7.0 to 2.10.0 | None |

Products: Fedoraproject Fedora, Redhat Ansible, Redhat Ansible Tower, Redhat Cloudforms Management Engine, Redhat Openstack.

## How do I fix CVE-2020-1736?

Upgrade ansible to a fixed version for your release line: 2.7.17, 2.8.9 or 2.9.6.

## Is CVE-2020-1736 being exploited?

There is no known exploitation of CVE-2020-1736 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-1736 and fix it if it is affected.

What it is: CVE-2020-1736 is a low-severity vulnerability in Fedoraproject Fedora, published on 16 Mar 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-1736 in the wild and no public exploit code.

Affected packages and fixed versions:
- ansible (PyPI): affected all versions; fixed in 2.7.17, 2.8.9, 2.9.6
- ansible (PyPI): affected from 2.7.0 up to 2.10.0; no fix listed
- ansible (PyPI): affected from 2.7.0 up to 2.10.0; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-1736/ (Markdown: https://insights.sbomify.com/CVE-2020-1736/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-1736
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-1736
- OSV: https://osv.dev/vulnerability/CVE-2020-1736

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-1736/
Summaries are generated and may contain mistakes; the official description above is the record.
