{"answers":{"affected":"7 open source packages ship an affected version, including ansible. It affects 2 products.","exploited":"There is no known exploitation of CVE-2020-1737 in the wild and no public exploit code.","fix":"Upgrade ansible to a fixed version for your release line: 2.7.17, 2.8.9 or 2.9.6.","what":"CVE-2020-1737 is a high-severity path traversal vulnerability in Redhat Ansible Tower, published on 9 Mar 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-1737 and fix it if it is affected.\n\nWhat it is: CVE-2020-1737 is a high-severity path traversal vulnerability in Redhat Ansible Tower, published on 9 Mar 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-1737 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ansible (PyPI): affected all versions; fixed in 2.7.17, 2.8.9, 2.9.6\n- ansible (PyPI): affected all versions; fixed in 2.7.17\n- ansible (PyPI): affected all versions; fixed in 2.7.17\n- ansible (PyPI): affected from 2.8.0a1; fixed in 2.8.9\n- ansible (PyPI): affected from 2.8.0a1; fixed in 2.8.9\n- ansible (PyPI): affected from 2.9.0a1; fixed in 2.9.6\n- ansible (PyPI): affected from 2.9.0a1; fixed in 2.9.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-1737/ (Markdown: https://insights.sbomify.com/CVE-2020-1737/index.md)","id":"CVE-2020-1737","markdown":"https://insights.sbomify.com/CVE-2020-1737/index.md","name":"CVE-2020-1737","record":{"aliases":["ALPINE-CVE-2020-1737","DEBIAN-CVE-2020-1737","GHSA-893h-35v4-mxqx","PYSEC-2020-9","UBUNTU-CVE-2020-1737"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_modify","code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Ansible automation tool","requires_auth":"low_privilege","summary":"An attacker can exploit path traversal in Ansible's win_unzip module to write files outside the destination directory, potentially leading to code execution.","user_interaction":"required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"ansible_engine","vendor":"redhat"},{"product":"ansible_tower","vendor":"redhat"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"A flaw was found in Ansible 2.7.17 and prior, 2.8.9 and prior, and 2.9.6 and prior when using the Extract-Zip function from the win_unzip module as the extracted file(s) are not checked if they belong to the destination folder. An attacker could take advantage of this flaw by crafting an archive anywhere in the file system, using a path traversal. This issue is fixed in 2.10.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Path Traversal in Ansible","id":"CVE-2020-1737","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"redhat:ansible_tower","products":["redhat:ansible_tower"],"type":"path_traversal","year":"2020"},"n_packages":7,"n_references":6,"next":{"headline":"Argument Injection in Ansible","id":"CVE-2020-1738"},"packages":[{"ecosystem":"PyPI","fixed":["2.7.17","2.8.9","2.9.6"],"introduced":["0","2.8.0","2.9.0"],"last_affected":[],"package":"ansible","purl":"pkg:pypi/ansible","source":"PYSEC-2020-9"},{"ecosystem":"PyPI","fixed":["2.7.17"],"introduced":["0"],"last_affected":[],"package":"ansible","purl":null,"source":"GHSA-893h-35v4-mxqx"},{"ecosystem":"PyPI","fixed":["2.7.17"],"introduced":["0"],"last_affected":[],"package":"ansible","purl":"pkg:pypi/ansible","source":"GHSA-893h-35v4-mxqx"},{"ecosystem":"PyPI","fixed":["2.8.9"],"introduced":["2.8.0a1"],"last_affected":[],"package":"ansible","purl":null,"source":"GHSA-893h-35v4-mxqx"},{"ecosystem":"PyPI","fixed":["2.8.9"],"introduced":["2.8.0a1"],"last_affected":[],"package":"ansible","purl":"pkg:pypi/ansible","source":"GHSA-893h-35v4-mxqx"},{"ecosystem":"PyPI","fixed":["2.9.6"],"introduced":["2.9.0a1"],"last_affected":[],"package":"ansible","purl":null,"source":"GHSA-893h-35v4-mxqx"},{"ecosystem":"PyPI","fixed":["2.9.6"],"introduced":["2.9.0a1"],"last_affected":[],"package":"ansible","purl":"pkg:pypi/ansible","source":"GHSA-893h-35v4-mxqx"}],"prev":{"headline":"Incorrect Permission Assignment for Critical Resource in Ansible","id":"CVE-2020-1736"},"products":["Ansible"],"published":"2020-03-09","related":[{"cvss_score":7.8,"headline":"Ansible Improper Input Validation vulnerability","id":"CVE-2018-10874","kev_date_added":null,"published":"2018-07-02"},{"cvss_score":7.4,"headline":"OS Command Injection in ansible","id":"CVE-2020-1734","kev_date_added":null,"published":"2020-03-03"},{"cvss_score":7.3,"headline":"Ansible leaks sensitive information to logs when told not to","id":"CVE-2019-14858","kev_date_added":null,"published":"2019-10-14"},{"cvss_score":5.2,"headline":"Path Traversal in Ansible","id":"CVE-2020-10691","kev_date_added":null,"published":"2020-04-30"},{"cvss_score":4.2,"headline":"Ansible Logs Passwords If PowerShell ScriptBlock is Enabled","id":"CVE-2018-16859","kev_date_added":null,"published":"2018-11-29"},{"cvss_score":2.2,"headline":"Improper Input Validation in ansible","id":"CVE-2016-8647","kev_date_added":null,"published":"2018-07-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Red Hat"]},"summary":"An attacker can exploit path traversal in Ansible's win_unzip module to write files outside the destination directory, potentially leading to code execution.","url":"https://insights.sbomify.com/CVE-2020-1737/"}