# CVE-2020-1737: Path Traversal in Ansible

> An attacker can exploit path traversal in Ansible's win_unzip module to write files outside the destination directory, potentially leading to code execution.

- **Severity:** High 7.5 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Mar 2020
- **Updated:** 4 Aug 2024
- **Also known as:** ALPINE-CVE-2020-1737, DEBIAN-CVE-2020-1737, GHSA-893h-35v4-mxqx, PYSEC-2020-9, UBUNTU-CVE-2020-1737

## What is CVE-2020-1737?

CVE-2020-1737 is a high-severity path traversal vulnerability in Redhat Ansible Tower, published on 9 Mar 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

A flaw was found in Ansible 2.7.17 and prior, 2.8.9 and prior, and 2.9.6 and prior when using the Extract-Zip function from the win_unzip module as the extracted file(s) are not checked if they belong to the destination folder. An attacker could take advantage of this flaw by crafting an archive anywhere in the file system, using a path traversal. This issue is fixed in 2.10.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2020-1737?

7 open source packages ship an affected version, including ansible. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ansible` | PyPI | All versions | 2.7.17, 2.8.9, 2.9.6 |
| `ansible` | PyPI | All versions | 2.7.17 |
| `ansible` | PyPI | All versions | 2.7.17 |
| `ansible` | PyPI | From 2.8.0a1 | 2.8.9 |
| `ansible` | PyPI | From 2.8.0a1 | 2.8.9 |
| `ansible` | PyPI | From 2.9.0a1 | 2.9.6 |
| `ansible` | PyPI | From 2.9.0a1 | 2.9.6 |

Products: Redhat Ansible Engine, Redhat Ansible Tower.

## How do I fix CVE-2020-1737?

Upgrade ansible to a fixed version for your release line: 2.7.17, 2.8.9 or 2.9.6.

## Is CVE-2020-1737 being exploited?

There is no known exploitation of CVE-2020-1737 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Ansible Tower

- [CVE-2018-10874](https://insights.sbomify.com/CVE-2018-10874/): Ansible Improper Input Validation vulnerability (high 7.8)
- [CVE-2020-1734](https://insights.sbomify.com/CVE-2020-1734/): OS Command Injection in ansible (high 7.4)
- [CVE-2019-14858](https://insights.sbomify.com/CVE-2019-14858/): Ansible leaks sensitive information to logs when told not to (high 7.3)
- [CVE-2020-10691](https://insights.sbomify.com/CVE-2020-10691/): Path Traversal in Ansible (medium 5.2)
- [CVE-2018-16859](https://insights.sbomify.com/CVE-2018-16859/): Ansible Logs Passwords If PowerShell ScriptBlock is Enabled (medium 4.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-1737 and fix it if it is affected.

What it is: CVE-2020-1737 is a high-severity path traversal vulnerability in Redhat Ansible Tower, published on 9 Mar 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-1737 in the wild and no public exploit code.

Affected packages and fixed versions:
- ansible (PyPI): affected all versions; fixed in 2.7.17, 2.8.9, 2.9.6
- ansible (PyPI): affected all versions; fixed in 2.7.17
- ansible (PyPI): affected all versions; fixed in 2.7.17
- ansible (PyPI): affected from 2.8.0a1; fixed in 2.8.9
- ansible (PyPI): affected from 2.8.0a1; fixed in 2.8.9
- ansible (PyPI): affected from 2.9.0a1; fixed in 2.9.6
- ansible (PyPI): affected from 2.9.0a1; fixed in 2.9.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-1737/ (Markdown: https://insights.sbomify.com/CVE-2020-1737/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-1737
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-1737
- OSV: https://osv.dev/vulnerability/CVE-2020-1737

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-1737/
Summaries are generated and may contain mistakes; the official description above is the record.
