{"answers":{"affected":"7 open source packages ship an affected version, including ansible. It affects 4 products.","exploited":"There is no known exploitation of CVE-2020-1738 in the wild and no public exploit code.","fix":"Upgrade ansible to a fixed version for your release line: 2.7.17, 2.8.9 or 2.9.6.","what":"CVE-2020-1738 is a low-severity command injection vulnerability in Redhat Ansible Tower, published on 16 Mar 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-1738 and fix it if it is affected.\n\nWhat it is: CVE-2020-1738 is a low-severity command injection vulnerability in Redhat Ansible Tower, published on 16 Mar 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-1738 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ansible (PyPI): affected all versions; fixed in 2.7.17, 2.8.9, 2.9.6\n- ansible (PyPI): affected all versions up to 2.7.16; no fix listed\n- ansible (PyPI): affected all versions up to 2.7.16; no fix listed\n- ansible (PyPI): affected from 2.8.0a1 up to 2.8.10; no fix listed\n- ansible (PyPI): affected from 2.8.0a1 up to 2.8.10; no fix listed\n- ansible (PyPI): affected from 2.9.0a1 up to 2.9.6; no fix listed\n- ansible (PyPI): affected from 2.9.0a1 up to 2.9.6; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-1738/ (Markdown: https://insights.sbomify.com/CVE-2020-1738/index.md)","id":"CVE-2020-1738","markdown":"https://insights.sbomify.com/CVE-2020-1738/index.md","name":"CVE-2020-1738","record":{"aliases":["DEBIAN-CVE-2020-1738","GHSA-f85h-23mf-2fwh","PYSEC-2020-10","UBUNTU-CVE-2020-1738"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Ansible automation tool","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary commands by manipulating Ansible facts when the 'use' parameter is omitted in package or service modules.","user_interaction":"required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"ansible","vendor":"redhat"},{"product":"ansible_tower","vendor":"redhat"},{"product":"cloudforms_management_engine","vendor":"redhat"},{"product":"openstack","vendor":"redhat"}],"cvss":{"score":3.9,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:N/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-88","name":"Improper Neutralization of Argument Delimiters in a Command"}],"description":"A flaw was found in Ansible Engine when the module package or service is used and the parameter 'use' is not specified. If a previous task is executed with a malicious user, the module sent can be selected by the attacker using the ansible facts file. All versions in 2.7.x, 2.8.x and 2.9.x branches are believed to be vulnerable.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Argument Injection in Ansible","id":"CVE-2020-1738","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"redhat:ansible_tower","products":["redhat:ansible_tower","redhat:openstack"],"type":"command_injection","year":"2020"},"n_packages":7,"n_references":3,"next":{"headline":"Exposure of Sensitive Information to an Unauthorized Actor in Ansible","id":"CVE-2020-1739"},"packages":[{"ecosystem":"PyPI","fixed":["2.7.17","2.8.9","2.9.6"],"introduced":["0","2.8.0","2.9.0"],"last_affected":[],"package":"ansible","purl":"pkg:pypi/ansible","source":"PYSEC-2020-10"},{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["2.7.16"],"package":"ansible","purl":null,"source":"GHSA-f85h-23mf-2fwh"},{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["2.7.16"],"package":"ansible","purl":"pkg:pypi/ansible","source":"GHSA-f85h-23mf-2fwh"},{"ecosystem":"PyPI","fixed":[],"introduced":["2.8.0a1"],"last_affected":["2.8.10"],"package":"ansible","purl":null,"source":"GHSA-f85h-23mf-2fwh"},{"ecosystem":"PyPI","fixed":[],"introduced":["2.8.0a1"],"last_affected":["2.8.10"],"package":"ansible","purl":"pkg:pypi/ansible","source":"GHSA-f85h-23mf-2fwh"},{"ecosystem":"PyPI","fixed":[],"introduced":["2.9.0a1"],"last_affected":["2.9.6"],"package":"ansible","purl":null,"source":"GHSA-f85h-23mf-2fwh"},{"ecosystem":"PyPI","fixed":[],"introduced":["2.9.0a1"],"last_affected":["2.9.6"],"package":"ansible","purl":"pkg:pypi/ansible","source":"GHSA-f85h-23mf-2fwh"}],"prev":{"headline":"Path Traversal in Ansible","id":"CVE-2020-1737"},"products":["ansible"],"published":"2020-03-16","related":[{"cvss_score":9.8,"headline":"Ansible Remote Code Execution","id":"CVE-2014-4657","kev_date_added":null,"published":"2020-02-20"},{"cvss_score":9.8,"headline":"Ansible Arbitrary Code Execution","id":"CVE-2014-4966","kev_date_added":null,"published":"2020-02-18"},{"cvss_score":9.8,"headline":"Ansible Arbitrary Code Execution","id":"CVE-2014-4967","kev_date_added":null,"published":"2020-02-18"},{"cvss_score":9.8,"headline":"Ansible Insertion of Sensitive Information into Log File vulnerability","id":"CVE-2017-7550","kev_date_added":null,"published":"2017-11-21"},{"cvss_score":8.8,"headline":"Ansible Arbitrary Code Execution","id":"CVE-2014-3498","kev_date_added":null,"published":"2017-06-08"},{"cvss_score":8,"headline":"Ansible Arbitrary Code Execution","id":"CVE-2017-7466","kev_date_added":null,"published":"2018-06-22"},{"cvss_score":7.8,"headline":"Ansible Sandbox Escape via Symlink Attack","id":"CVE-2015-6240","kev_date_added":null,"published":"2017-06-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Red Hat"]},"summary":"Attackers can execute arbitrary commands by manipulating Ansible facts when the 'use' parameter is omitted in package or service modules.","url":"https://insights.sbomify.com/CVE-2020-1738/"}