# CVE-2020-1738: Argument Injection in Ansible

> Attackers can execute arbitrary commands by manipulating Ansible facts when the 'use' parameter is omitted in package or service modules.

- **Severity:** Low 3.9 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Mar 2020
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2020-1738, GHSA-f85h-23mf-2fwh, PYSEC-2020-10, UBUNTU-CVE-2020-1738

## What is CVE-2020-1738?

CVE-2020-1738 is a low-severity command injection vulnerability in Redhat Ansible Tower, published on 16 Mar 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

A flaw was found in Ansible Engine when the module package or service is used and the parameter 'use' is not specified. If a previous task is executed with a malicious user, the module sent can be selected by the attacker using the ansible facts file. All versions in 2.7.x, 2.8.x and 2.9.x branches are believed to be vulnerable.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command)

## Which versions are affected by CVE-2020-1738?

7 open source packages ship an affected version, including ansible. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ansible` | PyPI | All versions | 2.7.17, 2.8.9, 2.9.6 |
| `ansible` | PyPI | All versions to 2.7.16 | None |
| `ansible` | PyPI | All versions to 2.7.16 | None |
| `ansible` | PyPI | From 2.8.0a1 to 2.8.10 | None |
| `ansible` | PyPI | From 2.8.0a1 to 2.8.10 | None |
| `ansible` | PyPI | From 2.9.0a1 to 2.9.6 | None |
| `ansible` | PyPI | From 2.9.0a1 to 2.9.6 | None |

Products: Redhat Ansible, Redhat Ansible Tower, Redhat Cloudforms Management Engine, Redhat Openstack.

## How do I fix CVE-2020-1738?

Upgrade ansible to a fixed version for your release line: 2.7.17, 2.8.9 or 2.9.6.

## Is CVE-2020-1738 being exploited?

There is no known exploitation of CVE-2020-1738 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Ansible Tower

- [CVE-2014-4657](https://insights.sbomify.com/CVE-2014-4657/): Ansible Remote Code Execution (critical 9.8)
- [CVE-2014-4966](https://insights.sbomify.com/CVE-2014-4966/): Ansible Arbitrary Code Execution (critical 9.8)
- [CVE-2014-4967](https://insights.sbomify.com/CVE-2014-4967/): Ansible Arbitrary Code Execution (critical 9.8)
- [CVE-2017-7550](https://insights.sbomify.com/CVE-2017-7550/): Ansible Insertion of Sensitive Information into Log File vulnerability (critical 9.8)
- [CVE-2014-3498](https://insights.sbomify.com/CVE-2014-3498/): Ansible Arbitrary Code Execution (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-1738 and fix it if it is affected.

What it is: CVE-2020-1738 is a low-severity command injection vulnerability in Redhat Ansible Tower, published on 16 Mar 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-1738 in the wild and no public exploit code.

Affected packages and fixed versions:
- ansible (PyPI): affected all versions; fixed in 2.7.17, 2.8.9, 2.9.6
- ansible (PyPI): affected all versions up to 2.7.16; no fix listed
- ansible (PyPI): affected all versions up to 2.7.16; no fix listed
- ansible (PyPI): affected from 2.8.0a1 up to 2.8.10; no fix listed
- ansible (PyPI): affected from 2.8.0a1 up to 2.8.10; no fix listed
- ansible (PyPI): affected from 2.9.0a1 up to 2.9.6; no fix listed
- ansible (PyPI): affected from 2.9.0a1 up to 2.9.6; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-1738/ (Markdown: https://insights.sbomify.com/CVE-2020-1738/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-1738
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-1738
- OSV: https://osv.dev/vulnerability/CVE-2020-1738

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-1738/
Summaries are generated and may contain mistakes; the official description above is the record.
