CVE-2020-1739 Exposure of Sensitive Information to an Unauthorized Actor in Ansible
An attacker with local access can read SVN passwords from process command lines when using the Ansible SVN module, exposing sensitive credentials.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2020-1739?
CVE-2020-1739 is a low-severity vulnerability in Debian Debian Linux, published on 12 Mar 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
A flaw was found in Ansible 2.7.16 and prior, 2.8.8 and prior, and 2.9.5 and prior when a password is set with the argument "password" of svn module, it is used on svn command line, disclosing to other users within the same node. An attacker could take advantage by reading the cmdline file from that particular PID on the procfs.
Weakness: CWE-200
Which versions are affected by CVE-2020-1739?
7 open source packages ship an affected version, including ansible. It affects 6 products.
| Package | Affected | Fixed in |
|---|---|---|
ansible PyPI | All versions | 2.7.17, 2.8.9, 2.9.6 |
ansible PyPI | All versions | 2.7.17 |
ansible PyPI | All versions | 2.7.17 |
ansible PyPI | From 2.8.0a1 | 2.8.11 |
ansible PyPI | From 2.8.0a1 | 2.8.11 |
ansible PyPI | From 2.9.0a1 | 2.9.7 |
1 more packages
ansible PyPI | From 2.9.0a1 | 2.9.7 |
Products include Debian Debian Linux, Fedoraproject Fedora, Redhat Ansible, Redhat Ansible Tower, Redhat Cloudforms Management Engine, Redhat Openstack.
How do I fix CVE-2020-1739?
Upgrade ansible to a fixed version for your release line: 2.7.17, 2.8.9, 2.9.6 or 2.8.11.
Is CVE-2020-1739 being exploited?
There is no known exploitation of CVE-2020-1739 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as ALPINE-CVE-2020-1739, CLSA-2025-1745052021, CLSA-2025-1746654462, DEBIAN-CVE-2020-1739, GHSA-923p-fr2c-g5m2, PYSEC-2020-11 and 1 more.