CVE-2020-1746 Exposure of Sensitive Information to an Unauthorized Actor in ansible
Ansible Engine leaks LDAP bind passwords to stdout or logs when using specific community modules, exposing sensitive credentials to attackers.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2020-1746?
CVE-2020-1746 is a medium-severity vulnerability in Debian Debian Linux, published on 12 May 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
A flaw was found in the Ansible Engine affecting Ansible Engine versions 2.7.x before 2.7.17 and 2.8.x before 2.8.11 and 2.9.x before 2.9.7 as well as Ansible Tower before and including versions 3.4.5 and 3.5.5 and 3.6.3 when the ldap_attr and ldap_entry community modules are used. The issue discloses the LDAP bind password to stdout or a log file if a playbook task is written using the bind_pw in the parameters field. The highest threat from this vulnerability is data confidentiality.
Weakness: CWE-200
Which versions are affected by CVE-2020-1746?
7 open source packages ship an affected version, including ansible. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
ansible PyPI | From 2.7.0 | 2.7.17, 2.8.11, 2.9.7 |
ansible PyPI | From 2.7.0a1 | 2.7.17 |
ansible PyPI | From 2.7.0a1 | 2.7.17 |
ansible PyPI | From 2.8.0a1 | 2.8.11 |
ansible PyPI | From 2.8.0a1 | 2.8.11 |
ansible PyPI | From 2.9.0a1 | 2.9.7 |
1 more packages
ansible PyPI | From 2.9.0a1 | 2.9.7 |
Products include Debian Debian Linux, Redhat Ansible Engine, Redhat Ansible Tower.
How do I fix CVE-2020-1746?
Upgrade ansible to a fixed version for your release line: 2.7.17, 2.8.11 or 2.9.7.
Is CVE-2020-1746 being exploited?
There is no known exploitation of CVE-2020-1746 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as ALPINE-CVE-2020-1746, DEBIAN-CVE-2020-1746, GHSA-j2h6-73x8-22c4, PYSEC-2020-13, UBUNTU-CVE-2020-1746.