# CVE-2020-1747: Improper Input Validation in PyYAML

> Attackers can execute arbitrary code by providing malicious YAML files to applications using PyYAML's full_load or FullLoader.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Mar 2020
- **Updated:** 4 Aug 2024
- **Also known as:** ALPINE-CVE-2020-1747, AZL-31783, DEBIAN-CVE-2020-1747, GHSA-6757-jp84-gxfx, MGASA-2020-0155, PYSEC-2020-96, SUSE-SU-2020:0959-1, SUSE-SU-2020:1285-1, openSUSE-SU-2020:0507-1, openSUSE-SU-2020:0630-1

## What is CVE-2020-1747?

CVE-2020-1747 is a critical code injection vulnerability in Fedoraproject Fedora, published on 24 Mar 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability was discovered in the PyYAML library in versions before 5.3.1, where it is susceptible to arbitrary code execution when it processes untrusted YAML files through the full_load method or with the FullLoader loader. Applications that use the library to process untrusted input may be vulnerable to this flaw. An attacker could use this flaw to execute arbitrary code on the system by abusing the python/object/new constructor.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2020-1747?

3 open source packages ship an affected version, including pyyaml. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyyaml` | PyPI | From 5.1 | 5.3.1 |
| `pyyaml` | PyPI | From 5.1b7 | 5.3.1 |
| `pyyaml` | PyPI | From 5.1b7 | 5.3.1 |
| `python-PyYAML` | SUSE:Enterprise Storage 5 | All versions | 5.1.2-26.12.1 |
| `python-PyYAML` | SUSE:HPE Helion OpenStack 8 | All versions | 5.1.2-26.12.1 |
| `python-PyYAML` | SUSE:Linux Enterprise High Availability Extension 12 SP1 | All versions | 5.1.2-26.12.1 |
| `python-PyYAML` | SUSE:Linux Enterprise High Availability Extension 12 SP2 | All versions | 5.1.2-26.12.1 |
| `python-PyYAML` | SUSE:Linux Enterprise Module for Advanced Systems Management 12 | All versions | 5.1.2-26.12.1 |
| `python-PyYAML` | SUSE:Linux Enterprise Module for Basesystem 15 SP1 | All versions | 5.1.2-6.6.1 |
| `python-PyYAML` | SUSE:Linux Enterprise Module for Containers 12 | All versions | 5.1.2-26.12.1 |
| `python-PyYAML` | SUSE:Linux Enterprise Module for Public Cloud 12 | All versions | 5.1.2-26.12.1 |
| `python-PyYAML` | SUSE:Linux Enterprise Module for Python 2 15 SP1 | All versions | 5.1.2-6.6.1 |
| `python-PyYAML` | SUSE:Linux Enterprise Point of Sale 12 SP2 | All versions | 5.1.2-26.12.1 |
| `python-PyYAML` | SUSE:Linux Enterprise Server 12 SP3-BCL | All versions | 5.1.2-26.12.1 |
| `python-PyYAML` | SUSE:Linux Enterprise Server 12 SP3-LTSS | All versions | 5.1.2-26.12.1 |
| `python-PyYAML` | SUSE:Linux Enterprise Server 12 SP4 | All versions | 5.1.2-26.12.1 |
| `python-PyYAML` | SUSE:Linux Enterprise Server 12 SP5 | All versions | 5.1.2-26.12.1 |
| `python-PyYAML` | SUSE:Linux Enterprise Server for SAP Applications 12 SP3 | All versions | 5.1.2-26.12.1 |
| `python-PyYAML` | SUSE:Linux Enterprise Server for SAP Applications 12 SP4 | All versions | 5.1.2-26.12.1 |
| `python-PyYAML` | SUSE:Linux Enterprise Server for SAP Applications 12 SP5 | All versions | 5.1.2-26.12.1 |
| `python-PyYAML` | SUSE:Manager Client Tools 12 | All versions | 5.1.2-26.12.1 |
| `python-PyYAML` | SUSE:Manager Proxy 3.2 | All versions | 5.1.2-26.12.1 |
| `python-PyYAML` | SUSE:Manager Server 3.2 | All versions | 5.1.2-26.12.1 |
| `python-PyYAML` | SUSE:OpenStack Cloud 6-LTSS | All versions | 5.1.2-26.12.1 |
| `python-PyYAML` | SUSE:OpenStack Cloud 7 | All versions | 5.1.2-26.12.1 |
| `python-PyYAML` | SUSE:OpenStack Cloud 8 | All versions | 5.1.2-26.12.1 |
| `python-PyYAML` | SUSE:OpenStack Cloud Crowbar 8 | All versions | 5.1.2-26.12.1 |
| `python-PyYAML` | openSUSE:Leap 15.1 | All versions | 5.1.2-lp151.2.13.1 |
| `python-PyYAML` | openSUSE:Leap 15.1 | All versions | 5.1.2-lp151.2.6.1 |

Products: Fedoraproject Fedora, Opensuse Leap, Oracle Communications Cloud Native Core Network Function Cloud Native Environment, Pyyaml Pyyaml.

## How do I fix CVE-2020-1747?

Upgrade pyyaml to 5.3.1 or later.

## Is CVE-2020-1747 being exploited?

There is no known exploitation of CVE-2020-1747 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-1747 and fix it if it is affected.

What it is: CVE-2020-1747 is a critical code injection vulnerability in Fedoraproject Fedora, published on 24 Mar 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-1747 in the wild and no public exploit code.

Affected packages and fixed versions:
- pyyaml (PyPI): affected from 5.1; fixed in 5.3.1
- pyyaml (PyPI): affected from 5.1b7; fixed in 5.3.1
- pyyaml (PyPI): affected from 5.1b7; fixed in 5.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-1747/ (Markdown: https://insights.sbomify.com/CVE-2020-1747/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-1747
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-1747
- OSV: https://osv.dev/vulnerability/CVE-2020-1747

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-1747/
Summaries are generated and may contain mistakes; the official description above is the record.
