# CVE-2020-17479: Validation bypass in jpv

> Attackers can cause a denial of service in the jpv library by providing corrupted array inputs that bypass validation.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Aug 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-vh6r-g38f-q3w8

## What is CVE-2020-17479?

CVE-2020-17479 is a critical vulnerability in n/a, published on 10 Aug 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

jpv (aka Json Pattern Validator) before 2.2.2 does not properly validate input, as demonstrated by a corrupted array.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2020-17479?

2 open source packages ship an affected version, including jpv. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jpv` | npm | All versions | 2.2.2 |
| `jpv` | npm | All versions | 2.2.2 |

Products: Json Pattern Validator Project Json Pattern Validator.

## How do I fix CVE-2020-17479?

Upgrade jpv to 2.2.2 or later.

## Is CVE-2020-17479 being exploited?

There is no known exploitation of CVE-2020-17479 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-19507](https://insights.sbomify.com/CVE-2019-19507/): Validation bypass is possible in Json Pattern Validator (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-17479 and fix it if it is affected.

What it is: CVE-2020-17479 is a critical vulnerability in n/a, published on 10 Aug 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-17479 in the wild and no public exploit code.

Affected packages and fixed versions:
- jpv (npm): affected all versions; fixed in 2.2.2
- jpv (npm): affected all versions; fixed in 2.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-17479/ (Markdown: https://insights.sbomify.com/CVE-2020-17479/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-17479
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-17479
- OSV: https://osv.dev/vulnerability/CVE-2020-17479

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-17479/
Summaries are generated and may contain mistakes; the official description above is the record.
