CVE-2020-17480 Cross-site scripting vulnerability in TinyMCE

Medium 6.1 Published Updated

Attackers can execute arbitrary scripts via XSS in TinyMCE by inserting malicious content through clipboard or APIs.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2020-17480?

CVE-2020-17480 is a medium-severity cross-site scripting vulnerability in n/a, published on 10 Aug 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

TinyMCE before 4.9.7 and 5.x before 5.1.4 allows XSS in the core parser, the paste plugin, and the visualchars plugin by using the clipboard or APIs to insert content into the editor.

Weakness: CWE-79

Which versions are affected by CVE-2020-17480?

4 open source packages ship an affected version, including tinymce. It affects 1 product.

PackageAffectedFixed in
tinymce npmAll versions4.9.7
tinymce npmAll versions4.9.7
tinymce npmFrom 5.0.05.1.4
tinymce npmFrom 5.0.05.1.4

Products include Tiny Tinymce.

How do I fix CVE-2020-17480?

Upgrade tinymce to a fixed version for your release line: 4.9.7 or 5.1.4.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2020-17480 being exploited?

There is no known exploitation of CVE-2020-17480 in the wild and no public exploit code.

Sources

Also known as CVE-2020-23066, GHSA-27gm-ghr9-4v95, UBUNTU-CVE-2020-17480.

Is CVE-2020-17480 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free