{"answers":{"affected":"4 open source packages ship an affected version, including tinymce. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-17480 in the wild and no public exploit code.","fix":"Upgrade tinymce to a fixed version for your release line: 4.9.7 or 5.1.4.","what":"CVE-2020-17480 is a medium-severity cross-site scripting vulnerability in n/a, published on 10 Aug 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-17480 and fix it if it is affected.\n\nWhat it is: CVE-2020-17480 is a medium-severity cross-site scripting vulnerability in n/a, published on 10 Aug 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-17480 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- tinymce (npm): affected all versions; fixed in 4.9.7\n- tinymce (npm): affected all versions; fixed in 4.9.7\n- tinymce (npm): affected from 5.0.0; fixed in 5.1.4\n- tinymce (npm): affected from 5.0.0; fixed in 5.1.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-17480/ (Markdown: https://insights.sbomify.com/CVE-2020-17480/index.md)","id":"CVE-2020-17480","markdown":"https://insights.sbomify.com/CVE-2020-17480/index.md","name":"CVE-2020-17480","record":{"aliases":["CVE-2020-23066","GHSA-27gm-ghr9-4v95","UBUNTU-CVE-2020-17480"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"TinyMCE rich text editor","requires_auth":"none","summary":"Attackers can execute arbitrary scripts via XSS in TinyMCE by inserting malicious content through clipboard or APIs.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"tinymce","vendor":"tiny"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"TinyMCE before 4.9.7 and 5.x before 5.1.4 allows XSS in the core parser, the paste plugin, and the visualchars plugin by using the clipboard or APIs to insert content into the editor.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site scripting vulnerability in TinyMCE","id":"CVE-2020-17480","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2020"},"n_packages":4,"n_references":2,"next":{"headline":"Information disclosure in n/a","id":"CVE-2020-17482"},"packages":[{"ecosystem":"npm","fixed":["4.9.7"],"introduced":["0"],"last_affected":[],"package":"tinymce","purl":null,"source":"GHSA-27gm-ghr9-4v95"},{"ecosystem":"npm","fixed":["4.9.7"],"introduced":["0"],"last_affected":[],"package":"tinymce","purl":"pkg:npm/tinymce","source":"GHSA-27gm-ghr9-4v95"},{"ecosystem":"npm","fixed":["5.1.4"],"introduced":["5.0.0"],"last_affected":[],"package":"tinymce","purl":null,"source":"GHSA-27gm-ghr9-4v95"},{"ecosystem":"npm","fixed":["5.1.4"],"introduced":["5.0.0"],"last_affected":[],"package":"tinymce","purl":"pkg:npm/tinymce","source":"GHSA-27gm-ghr9-4v95"}],"prev":{"headline":"Validation bypass in jpv","id":"CVE-2020-17479"},"products":["n/a"],"published":"2020-08-10","related":[{"cvss_score":8.7,"headline":"TinyMCE Cross-Site Scripting (XSS) vulnerability using through data-mce- prefixed src, href, style attributes","id":"CVE-2026-47759","kev_date_added":null,"published":"2026-05-28"},{"cvss_score":8.7,"headline":"TinyMCE Cross-Site Scripting (XSS) vulnerability using sanitization bypass through nested SVGs","id":"CVE-2026-47760","kev_date_added":null,"published":"2026-05-28"},{"cvss_score":8.7,"headline":"TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` injection","id":"CVE-2026-47761","kev_date_added":null,"published":"2026-05-28"},{"cvss_score":8.7,"headline":"TinyMCE Cross-Site Scripting (XSS) vulnerability through `mce:protected` comments","id":"CVE-2026-47762","kev_date_added":null,"published":"2026-05-28"},{"cvss_score":6.1,"headline":"Cross-site scripting vulnerability in TinyMCE","id":"CVE-2024-21908","kev_date_added":null,"published":"2024-01-03"},{"cvss_score":6.1,"headline":"Cross-site scripting vulnerability in TinyMCE plugins","id":"CVE-2024-21910","kev_date_added":null,"published":"2024-01-03"},{"cvss_score":6.1,"headline":"Cross-site scripting vulnerability in TinyMCE","id":"CVE-2024-21911","kev_date_added":null,"published":"2024-01-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Attackers can execute arbitrary scripts via XSS in TinyMCE by inserting malicious content through clipboard or APIs.","url":"https://insights.sbomify.com/CVE-2020-17480/"}