# CVE-2020-17480: Cross-site scripting vulnerability in TinyMCE

> Attackers can execute arbitrary scripts via XSS in TinyMCE by inserting malicious content through clipboard or APIs.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Aug 2020
- **Updated:** 4 Aug 2024
- **Also known as:** CVE-2020-23066, GHSA-27gm-ghr9-4v95, UBUNTU-CVE-2020-17480

## What is CVE-2020-17480?

CVE-2020-17480 is a medium-severity cross-site scripting vulnerability in n/a, published on 10 Aug 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

TinyMCE before 4.9.7 and 5.x before 5.1.4 allows XSS in the core parser, the paste plugin, and the visualchars plugin by using the clipboard or APIs to insert content into the editor.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-17480?

4 open source packages ship an affected version, including tinymce. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tinymce` | npm | All versions | 4.9.7 |
| `tinymce` | npm | All versions | 4.9.7 |
| `tinymce` | npm | From 5.0.0 | 5.1.4 |
| `tinymce` | npm | From 5.0.0 | 5.1.4 |

Products: Tiny Tinymce.

## How do I fix CVE-2020-17480?

Upgrade tinymce to a fixed version for your release line: 4.9.7 or 5.1.4.

## Is CVE-2020-17480 being exploited?

There is no known exploitation of CVE-2020-17480 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-47759](https://insights.sbomify.com/CVE-2026-47759/): TinyMCE Cross-Site Scripting (XSS) vulnerability using through data-mce- prefixed src, href, style attributes (high 8.7)
- [CVE-2026-47760](https://insights.sbomify.com/CVE-2026-47760/): TinyMCE Cross-Site Scripting (XSS) vulnerability using sanitization bypass through nested SVGs (high 8.7)
- [CVE-2026-47761](https://insights.sbomify.com/CVE-2026-47761/): TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` injection (high 8.7)
- [CVE-2026-47762](https://insights.sbomify.com/CVE-2026-47762/): TinyMCE Cross-Site Scripting (XSS) vulnerability through `mce:protected` comments (high 8.7)
- [CVE-2024-21908](https://insights.sbomify.com/CVE-2024-21908/): Cross-site scripting vulnerability in TinyMCE (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-17480 and fix it if it is affected.

What it is: CVE-2020-17480 is a medium-severity cross-site scripting vulnerability in n/a, published on 10 Aug 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-17480 in the wild and no public exploit code.

Affected packages and fixed versions:
- tinymce (npm): affected all versions; fixed in 4.9.7
- tinymce (npm): affected all versions; fixed in 4.9.7
- tinymce (npm): affected from 5.0.0; fixed in 5.1.4
- tinymce (npm): affected from 5.0.0; fixed in 5.1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-17480/ (Markdown: https://insights.sbomify.com/CVE-2020-17480/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-17480
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-17480
- OSV: https://osv.dev/vulnerability/CVE-2020-17480

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-17480/
Summaries are generated and may contain mistakes; the official description above is the record.
