# CVE-2020-17519: Apache Flink Improper Access Control

> Attackers can read arbitrary files on the JobManager filesystem via the REST API, exposing sensitive data to unauthorized users.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H`)
- **Exploited in the wild:** Yes, since 23 May 2024 (CISA KEV)
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Jan 2021
- **Updated:** 21 Oct 2025
- **Also known as:** BIT-flink-2020-17519, GHSA-395w-qhqr-9fr6

## What is CVE-2020-17519?

CVE-2020-17519 is a critical path traversal vulnerability in Apache Flink, published on 5 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A change introduced in Apache Flink 1.11.0 (and released in 1.11.1 and 1.11.2 as well) allows attackers to read any file on the local filesystem of the JobManager through the REST interface of the JobManager process. Access is restricted to files accessible by the JobManager process. All users should upgrade to Flink 1.11.3 or 1.12.0 if their Flink instance(s) are exposed. The issue was fixed in commit b561010b0ee741543c3953306037f00d7a9f0801 from apache/flink:master.

Weakness: CWE-552 (Files or Directories Accessible to External Parties)

## Which versions are affected by CVE-2020-17519?

5 open source packages ship an affected version, including org.apache.flink:flink-runtime_2.11, flink and org.apache.flink:flink-runtime_2.12. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.flink:flink-runtime_2.11` | Maven | From 1.11.0 | 1.11.3 |
| `org.apache.flink:flink-runtime_2.11` | Maven | From 1.11.0 | 1.11.3 |
| `flink` | Bitnami | From 1.11.0 | 1.11.3 |
| `org.apache.flink:flink-runtime_2.12` | Maven | From 1.11.0 | 1.11.3 |
| `org.apache.flink:flink-runtime_2.12` | Maven | From 1.11.0 | 1.11.3 |

Products: Apache Flink.

## How do I fix CVE-2020-17519?

Upgrade org.apache.flink:flink-runtime_2.11 to 1.11.3 or later. US federal agencies must fix it by 13 Jun 2024.

## Is CVE-2020-17519 being exploited?

Yes. Attackers have exploited CVE-2020-17519 in the wild since at least 23 May 2024.

Public exploit code:

- Tool check: CVE-2021-41773, CVE-2021-42013, CVE-2020-17519 (github_poc): https://github.com/MrCl0wnLab/SimplesApachePathTraversal
- Apache Flink 目录遍历漏洞批量检测 (CVE-2020-17519) (github_poc): https://github.com/B1anda0/CVE-2020-17519
- [CVE-2020-17519] Apache Flink RESTful API Arbitrary File Read (github_poc): https://github.com/murataydemir/CVE-2020-17519
- Apache Flink Directory Traversal (CVE-2020-17519) Nmap NSE Script (github_poc): https://github.com/dolevf/apache-flink-directory-traversal.nse
- https://github.com/QmF0c3UK/CVE-2020-17519 (github_poc): https://github.com/QmF0c3UK/CVE-2020-17519
- CVE-2020-17519; Apache Flink 任意文件读取; 批量检测 (github_poc): https://github.com/yaunsky/CVE-2020-17519-Apache-Flink

## Other vulnerabilities in Apache Flink

- [CVE-2026-35194](https://insights.sbomify.com/CVE-2026-35194/): Apache Flink: Remote code execution via SQL injection in code generation (high 8.1)
- [CVE-2020-17518](https://insights.sbomify.com/CVE-2020-17518/): Apache Flink directory traversal attack: remote file writing through the REST API (high 7.5)
- [CVE-2020-1960](https://insights.sbomify.com/CVE-2020-1960/): Command injection in Apache Flink (medium 4.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-17519 and fix it if it is affected.

What it is: CVE-2020-17519 is a critical path traversal vulnerability in Apache Flink, published on 5 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2020-17519 in the wild since at least 23 May 2024.

Affected packages and fixed versions:
- org.apache.flink:flink-runtime_2.11 (Maven): affected from 1.11.0; fixed in 1.11.3
- org.apache.flink:flink-runtime_2.11 (Maven): affected from 1.11.0; fixed in 1.11.3
- flink (Bitnami): affected from 1.11.0; fixed in 1.11.3
- org.apache.flink:flink-runtime_2.12 (Maven): affected from 1.11.0; fixed in 1.11.3
- org.apache.flink:flink-runtime_2.12 (Maven): affected from 1.11.0; fixed in 1.11.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-17519/ (Markdown: https://insights.sbomify.com/CVE-2020-17519/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-17519
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-17519
- OSV: https://osv.dev/vulnerability/CVE-2020-17519

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-17519/
Summaries are generated and may contain mistakes; the official description above is the record.
