CVE-2020-1753 Insertion of Sensitive Information into Log File, Invocation of Process Using Visible Sensitive Information, and Exposure of Sensitive Information to an Unauthorized Actor in Ansible
Ansible Engine exposes sensitive Kubernetes credentials in process lists and logs, allowing attackers to read secrets.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2020-1753?
CVE-2020-1753 is a medium-severity vulnerability in Debian Debian Linux, published on 16 Mar 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
A security flaw was found in Ansible Engine, all Ansible 2.7.x versions prior to 2.7.17, all Ansible 2.8.x versions prior to 2.8.11 and all Ansible 2.9.x versions prior to 2.9.7, when managing kubernetes using the k8s module. Sensitive parameters such as passwords and tokens are passed to kubectl from the command line, not using an environment variable or an input configuration file. This will disclose passwords and tokens from process list and no_log directive from debug module would not have any effect making these secrets being disclosed on stdout and log files.
Which versions are affected by CVE-2020-1753?
7 open source packages ship an affected version, including ansible. It affects 4 products.
| Package | Affected | Fixed in |
|---|---|---|
ansible PyPI | All versions | 2.7.18, 2.8.11, 2.9.7 |
ansible PyPI | From 2.7.0a1 | 2.7.18 |
ansible PyPI | From 2.7.0a1 | 2.7.18 |
ansible PyPI | From 2.8.0a1 | 2.8.12 |
ansible PyPI | From 2.8.0a1 | 2.8.12 |
ansible PyPI | From 2.9.0a1 | 2.9.7 |
1 more packages
ansible PyPI | From 2.9.0a1 | 2.9.7 |
Linux distribution packages (3)
ansible Red Hat:ansible_engine:2.7::el7 | All versions | 0:2.7.18-1.el7ae |
ansible Red Hat:ansible_engine:2.8::el7 | All versions | 0:2.8.16-1.el7ae |
ansible Red Hat:ansible_engine:2.8::el8 | All versions | 0:2.8.16-1.el8ae |
Products include Debian Debian Linux, Fedoraproject Fedora, Redhat Ansible Engine, Redhat Ansible Tower.
How do I fix CVE-2020-1753?
Upgrade ansible to a fixed version for your release line: 2.7.18, 2.8.11, 2.9.7 or 2.8.12.
Is CVE-2020-1753 being exploited?
There is no known exploitation of CVE-2020-1753 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2020-1753, GHSA-86hp-cj9j-33vv, PYSEC-2020-210, RHBA-2020:4195, RHSA-2020:2142, UBUNTU-CVE-2020-1753.