# CVE-2020-1753: Insertion of Sensitive Information into Log File, Invocation of Process Using Visible Sensitive Information, and Exposure of Sensitive Information to an Unauthorized Actor in Ansible

> Ansible Engine exposes sensitive Kubernetes credentials in process lists and logs, allowing attackers to read secrets.

- **Severity:** Medium 5.0 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Mar 2020
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2020-1753, GHSA-86hp-cj9j-33vv, PYSEC-2020-210, RHBA-2020:4195, RHSA-2020:2142, UBUNTU-CVE-2020-1753

## What is CVE-2020-1753?

CVE-2020-1753 is a medium-severity vulnerability in Debian Debian Linux, published on 16 Mar 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

A security flaw was found in Ansible Engine, all Ansible 2.7.x versions prior to 2.7.17, all Ansible 2.8.x versions prior to 2.8.11 and all Ansible 2.9.x versions prior to 2.9.7, when managing kubernetes using the k8s module. Sensitive parameters such as passwords and tokens are passed to kubectl from the command line, not using an environment variable or an input configuration file. This will disclose passwords and tokens from process list and no_log directive from debug module would not have any effect making these secrets being disclosed on stdout and log files.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File), CWE-214 (Invocation of Process Using Visible Sensitive Information), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2020-1753?

7 open source packages ship an affected version, including ansible. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ansible` | PyPI | All versions | 2.7.18, 2.8.11, 2.9.7 |
| `ansible` | PyPI | From 2.7.0a1 | 2.7.18 |
| `ansible` | PyPI | From 2.7.0a1 | 2.7.18 |
| `ansible` | PyPI | From 2.8.0a1 | 2.8.12 |
| `ansible` | PyPI | From 2.8.0a1 | 2.8.12 |
| `ansible` | PyPI | From 2.9.0a1 | 2.9.7 |
| `ansible` | PyPI | From 2.9.0a1 | 2.9.7 |
| `ansible` | Red Hat:ansible_engine:2.7::el7 | All versions | 0:2.7.18-1.el7ae |
| `ansible` | Red Hat:ansible_engine:2.8::el7 | All versions | 0:2.8.16-1.el7ae |
| `ansible` | Red Hat:ansible_engine:2.8::el8 | All versions | 0:2.8.16-1.el8ae |

Products: Debian Debian Linux, Fedoraproject Fedora, Redhat Ansible Engine, Redhat Ansible Tower.

## How do I fix CVE-2020-1753?

Upgrade ansible to a fixed version for your release line: 2.7.18, 2.8.11, 2.9.7 or 2.8.12.

## Is CVE-2020-1753 being exploited?

There is no known exploitation of CVE-2020-1753 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-1753 and fix it if it is affected.

What it is: CVE-2020-1753 is a medium-severity vulnerability in Debian Debian Linux, published on 16 Mar 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-1753 in the wild and no public exploit code.

Affected packages and fixed versions:
- ansible (PyPI): affected all versions; fixed in 2.7.18, 2.8.11, 2.9.7
- ansible (PyPI): affected from 2.7.0a1; fixed in 2.7.18
- ansible (PyPI): affected from 2.7.0a1; fixed in 2.7.18
- ansible (PyPI): affected from 2.8.0a1; fixed in 2.8.12
- ansible (PyPI): affected from 2.8.0a1; fixed in 2.8.12
- ansible (PyPI): affected from 2.9.0a1; fixed in 2.9.7
- ansible (PyPI): affected from 2.9.0a1; fixed in 2.9.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-1753/ (Markdown: https://insights.sbomify.com/CVE-2020-1753/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-1753
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-1753
- OSV: https://osv.dev/vulnerability/CVE-2020-1753

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-1753/
Summaries are generated and may contain mistakes; the official description above is the record.
