# CVE-2020-17530: Apache Struts Remote Code Execution

> Attackers can execute arbitrary code remotely by exploiting forced OGNL evaluation on raw user input in tag attributes.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Yes, since 3 Nov 2021 (CISA KEV)
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Dec 2020
- **Updated:** 21 Oct 2025
- **Also known as:** GHSA-jc35-q369-45pv

## What is CVE-2020-17530?

CVE-2020-17530 is a critical code injection vulnerability in Apache Struts, published on 11 Dec 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Forced OGNL evaluation, when evaluated on raw user input in tag attributes, may lead to remote code execution. Affected software : Apache Struts 2.0.0 - Struts 2.5.25.

Weakness: CWE-917 (Improper Neutralization of Special Elements used in an Expression Language Statement)

## Which versions are affected by CVE-2020-17530?

2 open source packages ship an affected version, including org.apache.struts:struts2-core. It affects 8 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.struts:struts2-core` | Maven | From 2.0.0 | 2.5.26 |
| `org.apache.struts:struts2-core` | Maven | From 2.0.0 | 2.5.26 |

Products: Apache Struts, Oracle Business Intelligence, Oracle Communications Diameter Intelligence Hub, Oracle Communications Policy Management, Oracle Communications Pricing Design Center, Oracle Financial Services Data Integration Hub, Oracle Hospitality Opera 5, Oracle Mysql Enterprise Monitor.

## How do I fix CVE-2020-17530?

Upgrade org.apache.struts:struts2-core to 2.5.26 or later. US federal agencies must fix it by 3 May 2022.

## Is CVE-2020-17530 being exploited?

Yes. Attackers have exploited CVE-2020-17530 in the wild since at least 3 Nov 2021.

Public exploit code:

- https://github.com/ka1n4t/CVE-2020-17530 (github_poc): https://github.com/ka1n4t/CVE-2020-17530
- S2-061 的payload，以及对应简单的PoC/Exp (github_poc): https://github.com/wuzuowei/CVE-2020-17530
- S2-061 CVE-2020-17530 (github_poc): https://github.com/Al1ex/CVE-2020-17530
- CVE-2020-17530-strust2-061 (github_poc): https://github.com/fengziHK/CVE-2020-17530-strust2-061
- https://github.com/uzzzval/CVE-2020-17530 (github_poc): https://github.com/uzzzval/CVE-2020-17530
- https://github.com/CyborgSecurity/CVE-2020-17530 (github_poc): https://github.com/CyborgSecurity/CVE-2020-17530

## Other vulnerabilities in Apache Struts

- [CVE-2017-9791](https://insights.sbomify.com/CVE-2017-9791/): Apache Struts 1 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2017-5638](https://insights.sbomify.com/CVE-2017-5638/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2012-0391](https://insights.sbomify.com/CVE-2012-0391/): Apache Struts 2 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2018-11776](https://insights.sbomify.com/CVE-2018-11776/): Apache Struts Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2017-9805](https://insights.sbomify.com/CVE-2017-9805/): Apache Struts Deserialization of Untrusted Data (high 8.1, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-17530 and fix it if it is affected.

What it is: CVE-2020-17530 is a critical code injection vulnerability in Apache Struts, published on 11 Dec 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2020-17530 in the wild since at least 3 Nov 2021.

Affected packages and fixed versions:
- org.apache.struts:struts2-core (Maven): affected from 2.0.0; fixed in 2.5.26
- org.apache.struts:struts2-core (Maven): affected from 2.0.0; fixed in 2.5.26

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-17530/ (Markdown: https://insights.sbomify.com/CVE-2020-17530/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-17530
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-17530
- OSV: https://osv.dev/vulnerability/CVE-2020-17530

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-17530/
Summaries are generated and may contain mistakes; the official description above is the record.
