# CVE-2020-17531: Deserialization flaw in EOL Tapestry 4.

> Unauthenticated attackers can execute arbitrary code via unsafe deserialization in the end-of-life Apache Tapestry 4 framework.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Dec 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-c566-2grg-mjwg

## What is CVE-2020-17531?

CVE-2020-17531 is a critical unsafe deserialization vulnerability in Apache Tapestry, published on 8 Dec 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A Java Serialization vulnerability was found in Apache Tapestry 4. Apache Tapestry 4 will attempt to deserialize the "sp" parameter even before invoking the page's validate method, leading to deserialization without authentication. Apache Tapestry 4 reached end of life in 2008 and no update to address this issue will be released. Apache Tapestry 5 versions are not vulnerable to this issue. Users of Apache Tapestry 4 should upgrade to the latest Apache Tapestry 5 version.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2020-17531?

2 open source packages ship an affected version, including org.apache.tapestry:tapestry-project. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tapestry:tapestry-project` | Maven | From 4.0 | 5.0.1 |
| `org.apache.tapestry:tapestry-project` | Maven | From 4.0 | 5.0.1 |

Products: Apache Tapestry.

## How do I fix CVE-2020-17531?

Upgrade org.apache.tapestry:tapestry-project to 5.0.1 or later.

## Is CVE-2020-17531 being exploited?

There is no known exploitation of CVE-2020-17531 in the wild and no public exploit code.

Public exploit code:

- Apache Struts2框架是一个用于开发Java EE网络应用程序的Web框架。Apache Struts于2020年12月08日披露 S2-061 Struts 远程代码执行漏洞（CVE-2020-17530），在使用某些tag等情况下可能存在OGNL表达式注入漏洞，从而造成远程代码执行，风险极大。提醒我校Apache Struts用户尽快采取安全措施阻止漏洞攻击。 (github_poc): https://github.com/154802388/CVE-2020-17531

## Other vulnerabilities in Apache Tapestry

- [CVE-2022-46366](https://insights.sbomify.com/CVE-2022-46366/): Apache Tapestry prior to version 4 (EOL) allows RCE though deserialization of untrusted input (critical 9.8)
- [CVE-2021-27850](https://insights.sbomify.com/CVE-2021-27850/): Bypass of the fix for CVE-2019-0195 (critical 9.8)
- [CVE-2019-0195](https://insights.sbomify.com/CVE-2019-0195/): Deserialization of Untrusted Data in Apache Tapestry (critical 9.8)
- [CVE-2019-10071](https://insights.sbomify.com/CVE-2019-10071/): Timing attack on HMAC signature comparison in Apache Tapestry (critical 9.8)
- [CVE-2014-1972](https://insights.sbomify.com/CVE-2014-1972/): Apache Tapestry Unsafe Object Storage (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-17531 and fix it if it is affected.

What it is: CVE-2020-17531 is a critical unsafe deserialization vulnerability in Apache Tapestry, published on 8 Dec 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-17531 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.tapestry:tapestry-project (Maven): affected from 4.0; fixed in 5.0.1
- org.apache.tapestry:tapestry-project (Maven): affected from 4.0; fixed in 5.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-17531/ (Markdown: https://insights.sbomify.com/CVE-2020-17531/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-17531
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-17531
- OSV: https://osv.dev/vulnerability/CVE-2020-17531

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-17531/
Summaries are generated and may contain mistakes; the official description above is the record.
