{"answers":{"affected":"4 open source packages ship an affected version, including org.apache.servicecomb:java-chassis. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-17532 in the wild and no public exploit code.","fix":"Upgrade org.apache.servicecomb:java-chassis to a fixed version for your release line: 1.3.2 or 2.1.5.","what":"CVE-2020-17532 is a high-severity unsafe deserialization vulnerability in Apache ServiceComb-Java-Chassis, published on 25 Jan 2021. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-17532 and fix it if it is affected.\n\nWhat it is: CVE-2020-17532 is a high-severity unsafe deserialization vulnerability in Apache ServiceComb-Java-Chassis, published on 25 Jan 2021. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-17532 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.servicecomb:java-chassis (Maven): affected from 1.0.0; fixed in 1.3.2\n- org.apache.servicecomb:java-chassis (Maven): affected from 1.0.0; fixed in 1.3.2\n- org.apache.servicecomb:java-chassis (Maven): affected from 2.0.0; fixed in 2.1.5\n- org.apache.servicecomb:java-chassis (Maven): affected from 2.0.0; fixed in 2.1.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-17532/ (Markdown: https://insights.sbomify.com/CVE-2020-17532/index.md)","id":"CVE-2020-17532","markdown":"https://insights.sbomify.com/CVE-2020-17532/index.md","name":"CVE-2020-17532","record":{"aliases":["GHSA-px4w-rcv2-6x8x"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Java microservice framework","requires_auth":"low_privilege","summary":"Authenticated users can achieve arbitrary code execution via unsafe deserialization when the handler-router component is enabled.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"java_chassis","vendor":"apache"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"When handler-router component is enabled in servicecomb-java-chassis, authenticated user may inject some data and cause arbitrary code execution. The problem happens in versions between 2.0.0 ~ 2.1.3 and fixed in Apache ServiceComb-Java-Chassis 2.1.5","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache ServiceComb Yaml remote deserialization vulnerability","id":"CVE-2020-17532","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"deserialization","year":"2020"},"n_packages":4,"n_references":2,"next":{"headline":"Apache Accumulo Improper Handling of Insufficient Permissions","id":"CVE-2020-17533"},"packages":[{"ecosystem":"Maven","fixed":["1.3.2"],"introduced":["1.0.0"],"last_affected":[],"package":"org.apache.servicecomb:java-chassis","purl":null,"source":"GHSA-px4w-rcv2-6x8x"},{"ecosystem":"Maven","fixed":["1.3.2"],"introduced":["1.0.0"],"last_affected":[],"package":"org.apache.servicecomb:java-chassis","purl":"pkg:maven/org.apache.servicecomb/java-chassis","source":"GHSA-px4w-rcv2-6x8x"},{"ecosystem":"Maven","fixed":["2.1.5"],"introduced":["2.0.0"],"last_affected":[],"package":"org.apache.servicecomb:java-chassis","purl":null,"source":"GHSA-px4w-rcv2-6x8x"},{"ecosystem":"Maven","fixed":["2.1.5"],"introduced":["2.0.0"],"last_affected":[],"package":"org.apache.servicecomb:java-chassis","purl":"pkg:maven/org.apache.servicecomb/java-chassis","source":"GHSA-px4w-rcv2-6x8x"}],"prev":{"headline":"Deserialization flaw in EOL Tapestry 4.","id":"CVE-2020-17531"},"products":["Apache ServiceComb-Java-Chassis"],"published":"2021-01-25","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2025-02-13","vendors":["Apache Software Foundation"]},"summary":"Authenticated users can achieve arbitrary code execution via unsafe deserialization when the handler-router component is enabled.","url":"https://insights.sbomify.com/CVE-2020-17532/"}