# CVE-2020-17533: Apache Accumulo Improper Handling of Insufficient Permissions

> Authenticated users with insufficient permissions can perform administrative actions like flushing tables or shutting down servers due to unchecked security function return values.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Dec 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-grc3-8q8m-4j7c

## What is CVE-2020-17533?

CVE-2020-17533 is a high-severity missing authorization vulnerability in Apache Accumulo, published on 29 Dec 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Apache Accumulo versions 1.5.0 through 1.10.0 and version 2.0.0 do not properly check the return value of some policy enforcement functions before permitting an authenticated user to perform certain administrative operations. Specifically, the return values of the 'canFlush' and 'canPerformSystemActions' security functions are not checked in some instances, therefore allowing an authenticated user with insufficient permissions to perform the following actions: flushing a table, shutting down Accumulo or an individual tablet server, and setting or removing system-wide Accumulo configuration properties.

Weakness: CWE-252 (Unchecked Return Value)

## Which versions are affected by CVE-2020-17533?

4 open source packages ship an affected version, including org.apache.accumulo:accumulo-master. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.accumulo:accumulo-master` | Maven | From 1.5.0 | 1.10.1 |
| `org.apache.accumulo:accumulo-master` | Maven | From 1.5.0 | 1.10.1 |
| `org.apache.accumulo:accumulo-master` | Maven | From 2.0.0 | 2.0.1 |
| `org.apache.accumulo:accumulo-master` | Maven | From 2.0.0 | 2.0.1 |

Products: Apache Accumulo.

## How do I fix CVE-2020-17533?

Upgrade org.apache.accumulo:accumulo-master to a fixed version for your release line: 1.10.1 or 2.0.1.

## Is CVE-2020-17533 being exploited?

There is no known exploitation of CVE-2020-17533 in the wild and no public exploit code.

Public exploit code:

- https://github.com/pazeray/CVE-2020-17533 (github_poc): https://github.com/pazeray/CVE-2020-17533

## Other vulnerabilities in Apache Accumulo

- [CVE-2023-34340](https://insights.sbomify.com/CVE-2023-34340/): Apache Accumulo: Accumulo 2.1.0 may incorrectly validate cached credentials (critical 9.8)
- [CVE-2026-62764](https://insights.sbomify.com/CVE-2026-62764/): Apache Accumulo: A user can trigger a graceful shutdown of services without the relevant system permissions (medium 5.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-17533 and fix it if it is affected.

What it is: CVE-2020-17533 is a high-severity missing authorization vulnerability in Apache Accumulo, published on 29 Dec 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-17533 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.accumulo:accumulo-master (Maven): affected from 1.5.0; fixed in 1.10.1
- org.apache.accumulo:accumulo-master (Maven): affected from 1.5.0; fixed in 1.10.1
- org.apache.accumulo:accumulo-master (Maven): affected from 2.0.0; fixed in 2.0.1
- org.apache.accumulo:accumulo-master (Maven): affected from 2.0.0; fixed in 2.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-17533/ (Markdown: https://insights.sbomify.com/CVE-2020-17533/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-17533
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-17533
- OSV: https://osv.dev/vulnerability/CVE-2020-17533

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-17533/
Summaries are generated and may contain mistakes; the official description above is the record.
