# CVE-2020-17534: Improper synchronization in Apache Netbeans HTML/Java API

> A race condition in the webkit subproject allows local attackers to escalate privileges by exploiting temporary file handling flaws.

- **Severity:** High 7.0 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Jan 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-ppc3-fpvh-7396, UBUNTU-CVE-2020-17534

## What is CVE-2020-17534?

CVE-2020-17534 is a high-severity vulnerability in Apache NetBeans HTML/Java API, published on 11 Jan 2021. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

There exists a race condition between the deletion of the temporary file and the creation of the temporary directory in `webkit` subproject of HTML/Java API version 1.7. A similar vulnerability has recently been disclosed in other Java projects and the fix in HTML/Java API version 1.7.1 follows theirs: To avoid local privilege escalation version 1.7.1 creates the temporary directory atomically without dealing with the temporary file: https://github.com/apache/netbeans-html4j/commit/fa70e507e5555e1adb4f6518479fc408a7abd0e6

Weakness: CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization)

## Which versions are affected by CVE-2020-17534?

2 open source packages ship an affected version, including org.netbeans.html:pom. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.netbeans.html:pom` | Maven | All versions | 1.7.1 |
| `org.netbeans.html:pom` | Maven | All versions | 1.7.1 |

Products: Apache Html\/Java Api.

## How do I fix CVE-2020-17534?

Upgrade org.netbeans.html:pom to 1.7.1 or later.

## Is CVE-2020-17534 being exploited?

There is no known exploitation of CVE-2020-17534 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-17534 and fix it if it is affected.

What it is: CVE-2020-17534 is a high-severity vulnerability in Apache NetBeans HTML/Java API, published on 11 Jan 2021. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-17534 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.netbeans.html:pom (Maven): affected all versions; fixed in 1.7.1
- org.netbeans.html:pom (Maven): affected all versions; fixed in 1.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-17534/ (Markdown: https://insights.sbomify.com/CVE-2020-17534/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-17534
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-17534
- OSV: https://osv.dev/vulnerability/CVE-2020-17534

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-17534/
Summaries are generated and may contain mistakes; the official description above is the record.
