CVE-2020-17551 Cross-site scripting (XSS)
Cross-site scripting in ImpressCMS admin module allows attackers to execute arbitrary remote code.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2020-17551?
CVE-2020-17551 is a medium-severity cross-site scripting vulnerability in n/a, published on 7 Oct 2020. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
ImpressCMS 1.4.0 is affected by XSS in modules/system/admin.php which may result in arbitrary remote code execution.
Weakness: CWE-79
Which versions are affected by CVE-2020-17551?
2 open source packages ship an affected version, including impresscms/impresscms. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
impresscms/impresscms Packagist | All versions | 1.4.1 |
impresscms/impresscms Packagist | All versions | 1.4.1 |
Products include Impresscms Impresscms.
How do I fix CVE-2020-17551?
Upgrade impresscms/impresscms to 1.4.1 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2020-17551 being exploited?
There is no known exploitation of CVE-2020-17551 in the wild and no public exploit code.
Other vulnerabilities in n/a
- CVE-2008-3453 Multiple unspecified vulnerabilities in ImpressCMS 1.0 have unknown impact and attack vectors, related to modules/admin.php and "a few files
- CVE-2021-26599 SQL Injection in ImpressCMS
- CVE-2021-26600 Type Confusion in ImpressCMS
- CVE-2022-24977 Path Traversal in ImpressCMS
- CVE-2022-50912 ImpressCMS 1.4.4 - Unrestricted File Upload
Sources
Also known as GHSA-j29g-g982-pwpv.