CVE-2020-1756 Cross-site scripting in Moodle
Insufficient input escaping in the PHP unit webrunner admin tool allows attackers to inject scripts, potentially leading to code execution or account takeover.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-1756?
CVE-2020-1756 is a high-severity cross-site scripting vulnerability in Moodle Moodle, published on 16 Aug 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
In Moodle before 3.8.2, 3.7.5, 3.6.9 and 3.5.11, insufficient input escaping was applied to the PHP unit webrunner admin tool.
Weakness: CWE-20
Which versions are affected by CVE-2020-1756?
1 open source package ship an affected version, including moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle Bitnami | From 3.5.0 | 3.5.11, 3.6.9, 3.7.5, 3.8.2 |
Products include Moodle Moodle.
How do I fix CVE-2020-1756?
Upgrade moodle to a fixed version for your release line: 3.5.11, 3.6.9, 3.7.5 or 3.8.2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2020-1756 being exploited?
There is no known exploitation of CVE-2020-1756 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2020-1756, GHSA-625r-4rf7-g699, UBUNTU-CVE-2020-1756.