{"answers":{"affected":"1 open source package ship an affected version, including moodle. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-1756 in the wild and no public exploit code.","fix":"Upgrade moodle to a fixed version for your release line: 3.5.11, 3.6.9, 3.7.5 or 3.8.2.","what":"CVE-2020-1756 is a high-severity cross-site scripting vulnerability in Moodle Moodle, published on 16 Aug 2022. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-1756 and fix it if it is affected.\n\nWhat it is: CVE-2020-1756 is a high-severity cross-site scripting vulnerability in Moodle Moodle, published on 16 Aug 2022. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-1756 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- moodle (Bitnami): affected from 3.5.0; fixed in 3.5.11, 3.6.9, 3.7.5, 3.8.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-1756/ (Markdown: https://insights.sbomify.com/CVE-2020-1756/index.md)","id":"CVE-2020-1756","markdown":"https://insights.sbomify.com/CVE-2020-1756/index.md","name":"CVE-2020-1756","record":{"aliases":["BIT-moodle-2020-1756","GHSA-625r-4rf7-g699","UBUNTU-CVE-2020-1756"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Moodle LMS","requires_auth":"high_privilege","summary":"Insufficient input escaping in the PHP unit webrunner admin tool allows attackers to inject scripts, potentially leading to code execution or account takeover.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"moodle","vendor":"moodle"}],"cvss":{"score":7.2,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"In Moodle before 3.8.2, 3.7.5, 3.6.9 and 3.5.11, insufficient input escaping was applied to the PHP unit webrunner admin tool.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site scripting in Moodle","id":"CVE-2020-1756","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"moodle:moodle","products":["moodle:moodle"],"type":"xss","year":"2020"},"n_packages":1,"n_references":1,"next":{"headline":"Improper Input Validation in Undertow","id":"CVE-2020-1757"},"packages":[{"ecosystem":"Bitnami","fixed":["3.5.11","3.6.9","3.7.5","3.8.2"],"introduced":["3.5.0","3.6.0","3.7.0","3.8.0"],"last_affected":[],"package":"moodle","purl":"pkg:bitnami/moodle","source":"BIT-moodle-2020-1756"}],"prev":{"headline":"Security feature bypass in Moodle","id":"CVE-2020-1755"},"products":["Moodle"],"published":"2022-08-16","related":[{"cvss_score":10,"headline":"File upload in n/a","id":"CVE-2006-4935","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Moodle does not properly validate module instance id","id":"CVE-2006-4936","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Unknown \"front page vulnerability with Moodle servers\" for Moodle before 1.3.2 has unknown impact and attack vectors.","id":"CVE-2004-2233","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Cross-site scripting in n/a","id":"CVE-2004-2235","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2004-2236","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Unknown vulnerability in Moodle before 1.3.4 has unknown impact and attack vectors, related to \"strings in Moodle texts.\"","id":"CVE-2004-2237","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Multiple unknown vulnerabilities in Moodle before 1.5.1 have unknown impact and attack vectors.","id":"CVE-2005-2247","kev_date_added":null,"published":"2005-07-12"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Insufficient input escaping in the PHP unit webrunner admin tool allows attackers to inject scripts, potentially leading to code execution or account takeover.","url":"https://insights.sbomify.com/CVE-2020-1756/"}