# CVE-2020-1756: Cross-site scripting in Moodle

> Insufficient input escaping in the PHP unit webrunner admin tool allows attackers to inject scripts, potentially leading to code execution or account takeover.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Aug 2022
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-moodle-2020-1756, GHSA-625r-4rf7-g699, UBUNTU-CVE-2020-1756

## What is CVE-2020-1756?

CVE-2020-1756 is a high-severity cross-site scripting vulnerability in Moodle Moodle, published on 16 Aug 2022. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

In Moodle before 3.8.2, 3.7.5, 3.6.9 and 3.5.11, insufficient input escaping was applied to the PHP unit webrunner admin tool.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2020-1756?

1 open source package ship an affected version, including moodle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle` | Bitnami | From 3.5.0 | 3.5.11, 3.6.9, 3.7.5, 3.8.2 |

Products: Moodle Moodle.

## How do I fix CVE-2020-1756?

Upgrade moodle to a fixed version for your release line: 3.5.11, 3.6.9, 3.7.5 or 3.8.2.

## Is CVE-2020-1756 being exploited?

There is no known exploitation of CVE-2020-1756 in the wild and no public exploit code.

## Other vulnerabilities in Moodle Moodle

- [CVE-2006-4935](https://insights.sbomify.com/CVE-2006-4935/): File upload in n/a (critical 10.0)
- [CVE-2006-4936](https://insights.sbomify.com/CVE-2006-4936/): Moodle does not properly validate module instance id (critical 10.0)
- [CVE-2004-2233](https://insights.sbomify.com/CVE-2004-2233/): Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors. (critical 10.0)
- [CVE-2004-2235](https://insights.sbomify.com/CVE-2004-2235/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2004-2236](https://insights.sbomify.com/CVE-2004-2236/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-1756 and fix it if it is affected.

What it is: CVE-2020-1756 is a high-severity cross-site scripting vulnerability in Moodle Moodle, published on 16 Aug 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-1756 in the wild and no public exploit code.

Affected packages and fixed versions:
- moodle (Bitnami): affected from 3.5.0; fixed in 3.5.11, 3.6.9, 3.7.5, 3.8.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-1756/ (Markdown: https://insights.sbomify.com/CVE-2020-1756/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-1756
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-1756
- OSV: https://osv.dev/vulnerability/CVE-2020-1756

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-1756/
Summaries are generated and may contain mistakes; the official description above is the record.
