# CVE-2020-1760: Cross-site scripting in ceph

> An attacker can execute arbitrary scripts in the Ceph Object Gateway via untrusted input in anonymous S3 requests, potentially compromising user sessions.

- **Severity:** Medium 5.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Apr 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-ceph-2020-1760, DEBIAN-CVE-2020-1760, DLA-2171-1, GHSA-gj74-48rr-85f7, SUSE-SU-2020:0962-1, UBUNTU-CVE-2020-1760

## What is CVE-2020-1760?

CVE-2020-1760 is a medium-severity cross-site scripting vulnerability in Canonical Ubuntu Linux, published on 23 Apr 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A flaw was found in the Ceph Object Gateway, where it supports request sent by an anonymous user in Amazon S3. This flaw could lead to potential XSS attacks due to the lack of proper neutralization of untrusted input.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-1760?

1 open source package ship an affected version, including ceph. It affects 6 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ceph` | Bitnami | All versions | 14.2.21 |
| `ceph` | SUSE:Enterprise Storage 5 | All versions | 12.2.12+git.1585658687.363df3a813-2.42.4 |
| `ceph` | SUSE:Linux Enterprise Server 12 SP4 | All versions | 12.2.12+git.1585658687.363df3a813-2.42.4 |
| `ceph` | SUSE:Linux Enterprise Server 12 SP5 | All versions | 12.2.12+git.1585658687.363df3a813-2.42.4 |
| `ceph` | SUSE:Linux Enterprise Server for SAP Applications 12 SP4 | All versions | 12.2.12+git.1585658687.363df3a813-2.42.4 |
| `ceph` | SUSE:Linux Enterprise Server for SAP Applications 12 SP5 | All versions | 12.2.12+git.1585658687.363df3a813-2.42.4 |
| `ceph` | SUSE:Linux Enterprise Software Development Kit 12 SP4 | All versions | 12.2.12+git.1585658687.363df3a813-2.42.4 |
| `ceph` | SUSE:Linux Enterprise Software Development Kit 12 SP5 | All versions | 12.2.12+git.1585658687.363df3a813-2.42.4 |

Products: Canonical Ubuntu Linux, Debian Debian Linux, Fedoraproject Fedora, Linuxfoundation Ceph, Redhat Ceph Storage, Redhat Openshift Container Platform.

## How do I fix CVE-2020-1760?

Upgrade ceph to 14.2.21 or later.

## Is CVE-2020-1760 being exploited?

There is no known exploitation of CVE-2020-1760 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-1760 and fix it if it is affected.

What it is: CVE-2020-1760 is a medium-severity cross-site scripting vulnerability in Canonical Ubuntu Linux, published on 23 Apr 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-1760 in the wild and no public exploit code.

Affected packages and fixed versions:
- ceph (Bitnami): affected all versions; fixed in 14.2.21

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-1760/ (Markdown: https://insights.sbomify.com/CVE-2020-1760/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-1760
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-1760
- OSV: https://osv.dev/vulnerability/CVE-2020-1760

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-1760/
Summaries are generated and may contain mistakes; the official description above is the record.
