# CVE-2020-18327: Cross-site scripting in n/a

> An attacker can execute arbitrary scripts in the victim's browser via the admin-nodebrowser API, potentially leading to session hijacking or data theft.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 4 Mar 2022
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-alfresco-2020-18327, GHSA-r82g-4j97-fq26

## What is CVE-2020-18327?

CVE-2020-18327 is a medium-severity cross-site scripting vulnerability in n/a, published on 4 Mar 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross Site Scripting (XSS) vulnerability exists in Alfresco Alfresco Community Edition v5.2.0 via the action parameter in the alfresco/s/admin/admin-nodebrowser API. Fixed in v6.2

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-18327?

1 open source package ship an affected version, including alfresco. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `alfresco` | Bitnami | From 5.2.0 to 5.2.0 | None |

Products: Alfresco Alfresco.

## How do I fix CVE-2020-18327?

No fix has been published for CVE-2020-18327 yet. Limit exposure of the affected software until one is available.

## Is CVE-2020-18327 being exploited?

There is no known exploitation of CVE-2020-18327 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-14222](https://insights.sbomify.com/CVE-2019-14222/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2019-15566](https://insights.sbomify.com/CVE-2019-15566/): SQL injection in n/a (critical 9.8)
- [CVE-2019-14224](https://insights.sbomify.com/CVE-2019-14224/): Deserialization in n/a (high 7.2)
- [CVE-2014-9300](https://insights.sbomify.com/CVE-2014-9300/): Cross-site request forgery in n/a (medium 6.8)
- [CVE-2014-9301](https://insights.sbomify.com/CVE-2014-9301/): Server-side request forgery in n/a (medium 6.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-18327 and fix it if it is affected.

What it is: CVE-2020-18327 is a medium-severity cross-site scripting vulnerability in n/a, published on 4 Mar 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-18327 in the wild and no public exploit code.

Affected packages and fixed versions:
- alfresco (Bitnami): affected from 5.2.0 up to 5.2.0; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-18327/ (Markdown: https://insights.sbomify.com/CVE-2020-18327/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-18327
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-18327
- OSV: https://osv.dev/vulnerability/CVE-2020-18327

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-18327/
Summaries are generated and may contain mistakes; the official description above is the record.
