# CVE-2020-19000: Cross Site Scripting (XSS) in Simiki

> Remote attackers can execute arbitrary code via Cross-Site Scripting in the Simiki static site generator library.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Aug 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-fqr5-qphf-vfr8, PYSEC-2021-347

## What is CVE-2020-19000?

CVE-2020-19000 is a medium-severity cross-site scripting vulnerability in n/a, published on 27 Aug 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross Site Scripting (XSS) in Simiki v1.6.2.1 and prior allows remote attackers to execute arbitrary code via line 54 of the component 'simiki/blob/master/simiki/generators.py'.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-19000?

3 open source packages ship an affected version, including simiki. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `simiki` | PyPI | All versions | None |
| `simiki` | PyPI | All versions | 1.6.2.2 |
| `simiki` | PyPI | All versions | 1.6.2.2 |

Products: Simiki Project Simiki.

## How do I fix CVE-2020-19000?

Upgrade simiki to 1.6.2.2 or later.

## Is CVE-2020-19000 being exploited?

There is no known exploitation of CVE-2020-19000 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-19001](https://insights.sbomify.com/CVE-2020-19001/): Command Injection in Simiki (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-19000 and fix it if it is affected.

What it is: CVE-2020-19000 is a medium-severity cross-site scripting vulnerability in n/a, published on 27 Aug 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-19000 in the wild and no public exploit code.

Affected packages and fixed versions:
- simiki (PyPI): affected all versions; no fix listed
- simiki (PyPI): affected all versions; fixed in 1.6.2.2
- simiki (PyPI): affected all versions; fixed in 1.6.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-19000/ (Markdown: https://insights.sbomify.com/CVE-2020-19000/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-19000
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-19000
- OSV: https://osv.dev/vulnerability/CVE-2020-19000

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-19000/
Summaries are generated and may contain mistakes; the official description above is the record.
